Borders are thicker than in Excel

When I open a file created in Excel with borders at cells, these cells are thicker than they look in Excel. This makes the tables hard to read and hard to understand.

I’d like to see the document in my Calc as it was created in Excel. Is this possible or do I need to live with the changes?

This is a problem for many years see here.

Goto Tools → Options: in Libreoffice - view uncheck “use Anti-Aliasing”. It worked fairly good for me.

Thanks, this works for me too.

The relevant Bug 56960 - FILEOPEN particular .xlsx shows cell border lines with wrong FORMATTING (too thick) has been fixed (LibreOffice 4.1.0).

The solution mentioned above does not work for me. Any other suggestions?