[bug?] How to remove character formatting with one command/button?


Win 8, x64, C2D, Dell, 8 GB RAM.
In our company we have just moved from OO 3.2.1 to LO 4.1.4, and unfortunately it is not the best choice. Many reasonable for a fast editing work behaviours, options present in OO here are gone.
Among them there is some buggy thing in removing character formatting:
when I change some signs kerning and position, underline and some other formatting I cannot restore Default font and paragraph by using option “Clear/remove formatting”. It changes paragraph style to Default, but does not change character formatting, ie. kerning, color and others stay the same, formatted, not cleared.
In OO it worked perfectly: using one option from the Style list “Remove formatting” was clearing any additional formatting, and restoring pure Default style with the default character look.

Now, in LO, to get the same result I have to MANUALLY remove all the additional character formatting, that is marking characters, RMB, Character and setting all the changed format to default. Then Enter and I am happy. :wink:

Any clue?

Truly grateful for some solution,

If you apply the Default Style character style to the selected text it will remove any applied character style.

EDIT: Note that applying the Default Style character style will not remove any direct formatting. Direct formatting is removed via Format > Clear Direct Formatting….

Thank you, oweng, I did it.
And surprisingly, sometimes it works, sometimes–leaves even simple formatting like bold. And then the only way to remove it is to mark all the text Bold, and then turn it off.
One option for clearing all the text, paragraph, character to default should be available to be sure one works on clear text.