Bug in Chinese input under Mint 17.2

I am using the current version of LibreOffice Writer ( under Mint 17.2 Mate on a PC, all updated. I have installed Chinese (I use the AR PL Uminf CN font, and never had any problem with Chinese input under previous versions of LO. With the current version, when I type the pinyin and identify the characters among those offered, what gets inserted in the file is not Chinese but the error message “[Invalid UTF-8].” It is actually spelled out, so that the letters have to be erased one at a time.I have never specified UTF-8, and have not changed the font. Any idea what this is about?

As I understand LO it is UTF-8 by default.

What do you have in LO under Tools - Options - Language Settings - Languages?

How does that compare with your locale from a Terminal? (they are supposed to match)

:~$ locale


I managed to get the point of the error message "[Invalid UTF-8].". Certain bytes are invalid in UTF-8. That does not, of course, explain why there are invalid bytes in the string, but does help constrain the possible reasons.

If this helps then please tick the answer (:heavy_check_mark:).

In Options, my nlocale is English (USA)
In termihal, I get

I have no idea whether these correspond. Do they suggtest an answer?

Well they match, nsivin, which is the main thing (although, of course, it is not ZH). Also, your locale is utf8, which should remove most problems there. Now what about the font that you are using; is it utf8 also? Beyond that point I am out of ideas, as I have never come across your issue nor know where to start.

I uninstalled Chinese and then installed, first, a UTF-8 and, after getting rid of that, a GBK font. Both of them yield the same error. Since I had no problem at all with previous versions of Mint, it looks like this is a genuine bug in v. 17.2. Unless someone can solve this problem, I’ll have to go back to v. 17 or 17.1.

In fact, I discovered that I had encountered the same problem in 17.1 (no one responded to my earlier question about that.

I finally had to give up and go back to Mint 17, which lacked this bug. But if it isn’t fixed, when 17 LTS runs out, I’ll have to give up on Mint, since (like quite a lot of other people in the world) I have to use Chinese input along with English.

A frustrating problem. I hope these notes might help.
Have you checked to see whether there are known problems in this area with your IBUS or your fcitx whichever you are using? You may find the following website to be useful as it refers to the problems of invalid UTF-8 and Pinyin http://www.pinyinjoe.com/linux/ubuntu-12-chinese-setup.html. Invalid UTF-8 is more likely to be the input system rather than LibO. Sometimes the input system can confuse UTF-8 with UTF-16 or UTF-32. If the font is missing the characters, you do not get this type of error but a blank rectangular symbol.

I am using Linux Mint Mate 17.2 with LibO 5.0.5 and 4.4.3. I can enter some Pinyin characters with my limited knowledge of the particular character sets and using a standard Linux font Lucida Sans Unicode. I use the two techniques, with insert special characters and inputting the Unicode directly. Only characters available in the font are available to choose. Lucida Sans Unicode contains the Latin Extended-B Characters as defined in the Chinese ISO 6438, but not the Chinese symbols.

1 ) Select the Font Lucida Sans Unicode.
Choose your characters. For example
ǔ nj lj ƥ Ɔ Ƌ Ǝ Ƒ Ɯ Lj ƙ ǔ Ǔ Ǘ ǖ

2b) You can also enter the Unicode directly by pressing CTRL /SHIFT together U + code. For example U+1D3 gives Ǔ+ 19C Ɯ.

I encountered the same problem. I’m using Mint 17.2 KDE and ibus as input method. The workaround was quite easy. I tried Ibus sunpinyin instead of ibus pinyin and it seems to work well.

BTW, do you happen to be Nathan Sivin from University of Pennsylvania? I’m an admirer of your work and the studying advices on your website helped me a lot. Thank you.