C.ppsx open and automatically close itself without giving any control. What is this? Why?

When I open the document (aka C.ppsx), I can barely do anything. When I click the document, the first slide will open in fullscreen automatically. And when I press Esc to see Slide Pane Libre Impress shut itself down as if I am trying to exit the application. This all happens in a matter of a few seconds. I want to modify the answer written on it as per the document owner (my friend) requested. No LO options are responding to the document.

Do let me know. Why the document is acting like a ‘fish on the ground’? I can’t seem to catch this fish. Too slippery. Do I need to install Microsoft sh*t?

I can’t even attach this document. I tried. Not allowed file format.

File extension is changed from .ppsx to .pptx but have a similar effect like I was talking about. No difference. Same effect.

If you want attach a file being not allowed, change the extension to an allowed one (.e.g .odp) and leave a comment having done so and mention the original extension.

@anon73440385 I added that file. Please do have a lot at it. I want to see if u can edit the file or add new slides in it. Because I can’t for some reason.

Saving as a slideshow file is a conscious decision. It is not likely to happen by accident.

The most common purpose of saving as slideshow is an automated presentation, requiring minimal user intervention. IOW, to make it easy for the presenter.

It is also used by some people as a protection scheme: Allow presentation, but disallow modification and further use of content.

So, if your friend owns the document, two questions for him/you:

  • Why ask other people to change the file? Could he not do it himself?
  • Why save it as a slideshow when it is meant to be edited?

Until I get a sensible explanation to the above, I am open to the possibility that the true owner of intellectual property in this case is some other party. In other words, you may have lied to us, your friend may have lied to you, or you may have a perception of intellectual property different from what is commonly assumed. Nothing I can do about it, other than stating my belief openly and hoping that I am wrong.

@keme The file Copywrite belongs to my friend. And he is not very technical to know about these things. The way he wrote in the document is pretty self-explanatory. It’s a very ugly presentation. He created and forwarded it to me to complete. Anyway, the problem is solved.


ppsx format is designed to be presented only and not to be modified. Anyway the following worked form me to convert it to .odp and hence being able to edit the file:

ibreoffice6.4 --convert-to odp ./C.ppsx

See the result: C.odp

Tested using LibreOffice:

Version:; Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kf5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US; Calc: threaded

Right-clicking on slides during PPSX presentation also provides a presentation editing option.

(I would love to see how OP, who constantly comes here with unwarranted pretensions, would do that with “Microsoft …”.)

@mikekaganski You are right. Right-clicking on the slide did give me the right to edit. Thanks. That was so easy. Never see that coming. I use LO Writer more than LO Impress because I have to write a lot. Anyway, that was SOOOO dumb of me. The whole way how the document opened in fullscreen presentation mode & ESC key exited the document instead of exiting fullscreen mode made up my mind to think it’s impossible to edit this file.
Anyway, thanks a lot. And sorry for being pretentious. I will try to cool it down. Take me as a noob LO user. I am using LO for about 2 years now. It’s hard to get used to it. I will try my best.

@anon73440385 Thanks for helping but I didn’t use that method. I look complicated. I got this warning: Imgur: The magic of the Internet when I edited file extension to ODP by pressing right-click. And this is another error message followed by the first error message: Imgur: The magic of the Internet. Do I have to change the file extension from the terminal?

@Pranav: what @anon73440385 did was not renaming, that was converting - it means, opening one file type, then writing the information into another file type (so the bytes in the files are different). Renaming the extension doesn’t do that, neither using right-click, nor from terminal.

Sigh …

I still don’t get it. libreoffice6.4 --convert-to odp ./C.ppsx looked more like a command to me.

Sigh …