Calc 4: cells does not recognize dates with dash in it

When i’m in a cell with date format and i write “1-1-13”, calc does not recognize the value as a date and it doesn’t change to the format selected.

In Calc 3.6, this behavior was unusual and the cell was recognized as a date.

What could it be the problem?

Thanks in advance.

I am currently using LibreOffice and 1-1-13 is also recognized as date. I suggest to create a new profile (rename old one and new one will be created at LibreOffice startup). If the problem persists then this is most probably a bug and report it:

NOT confirmed. In LibreOffice (Build ID: 2c0c17a6e4bee0ee28131ea4bdc47edc700d659) everything is fine. “1-1-13” is recognized as date. Try to reset user profile It may help in such strange situations.

Well, I have tried to reset user profile and the behavior persist. I’m going to test with version Now, i have installed I will comment the results. :wink:

Try add new paterns in Tools-Options-Language Settings-Languages in field Date accetpance patterns D-M or M-D or something else.

Take a look to this thread:

Correct, that is the solution. Thanks you very much, B.Horvat. Only i had to add the patterns D-M and D-M-Y to work correctly.

Thanks for all the answers.

I made a test in Version (Build ID: 5b93205) on XPprof/SP3 using the default Calc sheet.

When I enter 13-02-28 I get 2013-02-28 the default format is yyyy-mm-dd

When I enter 28-02-13 I get 2028-02-13 which is correct when looking at the format

Thus Calc understands “-” correct.

As I have Japanese installed as well, the date format yyyy-mm-dd could come from the Japanese setting. I am not sure what the default setting in other languages is

When I replace the “-” by “/” in the same sheet the situation is

Entering 13/02/28 results in 2月 28日 which is again correct but the year is skipped. Again here come the language setting into the game because the character after 02 is Japanese for month and after 28 is the Japanese character for day.
(If you only see wingdings after the figures there are Japanese fonts missing on AskLibO or your PC.)

I installed version (Build ID: 2c0c17a6e4bee0ee28131ea4bdc47edc700d659) and the test results are better.

If I enter 02/02/13, I get the format established 02/02/2013. But in 3.6, if I enter 2-2 in a cell formatted as a date, I get 02/02/2013 (current year). In version this behavior is not included.

I tried also resetting the user profile but the behavior is the same.

Any ideas?

If nobody has any idea, i will report it as a bug.


Tested in and Behavior is absolutely identical. If we format cell as date and enter in it 02-02-13, we get 02-02-2013. If we enter 02-02 (or 2-2) in a cell formatted as a date we get 02-02 (or 2-2) without any changes. But in 3.6.5 were fixed many problems with date format
For some unknown reason they were not applied to 4.x version. Already reported for both problems “In LibreOffice (Build ID: 2c0c17a6e4bee0ee28131ea4bdc47edc700d659) problem is still present.”