Calc and Writer (ver 7.0) are extremely SLOW

Calc loads fast (normal), but its response during “normal operation” is extremely slow. By “normal operation” I mean eg selecting columns, selecting cells, scrolling down, etc. in a medium (or even small)-sized spreadsheet.
For example, in a spreadsheet with 100 rows and 10 columns, it behaves really slow, as if it was dealing with thousands of rows and columns.
Writer shows similar behavior when navigating through a regular 10-pages ODT file (created with LO) with text, images, bookmarks, etc. nothing extraordinary.

The overall behavior of LO7 is much, much slower than previous versions for the same files.

I use latest light-weight Linux (Lubuntu 20.04) installed on SSD with a lare swap file and 8GB of RAM, so I don’t expect the problem comes from there (also, all the other software has no problems at all related to speed and memory)

I tried completely uninstalling LO and reinstalling. No changes.

What can I do next? I love LO and I am willing to do any other test you suggest to find the problem.

Thanks!

You just mention “(ver 7.0)”, which is not extremely precise, since there is 7.0.0.3, 7.0.1.2, 7.0.2.2 and 7.0.3.1 (just to mention the releases). In addition, each distribution releases their own packages of LibreOffice. Therefore - in case of using a GNU/Linux distribution it is important to mention the repository being used, which could be Base (not using a PPA), PPA repo or TDF (=libreoffice.org) native packages.

What about performance (all just tests to narrow down where the issue comes from)

  • running LibreOffice in Safe Mode (Help -> Restart in Safe Mode)
  • using native TDF Packages
  • starting LibreOffice from a terminal program (command line) using SAL_USE_VCLPLUGIN=gen libreoffice (Don’t worry about the look&feel)

?

And with or without anti-aliasing (Tools > Options > LibreOffice > View), with or without hardware acceleration, and yes, sometimes acceleration does the opposite with broken drivers.

Thanks for your replies! I must add to my description that even with an empty spreadsheet the normal operation is unexpectedly slow…

Here’s more details:

###Version details
Version: 7.0.3.1 (but it happens since 7.0.X.X)
Build ID: 00(Build:1)
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Ubuntu package version: 1:7.0.3-0ubuntu0.20.04.1
Calc: threaded

###Repository being used
Repository: Index of /libreoffice/ppa/ubuntu
Distribution: focal
Components: main

###Antialiasing and hardware acceleration options
Do not make any difference.

###running LibreOffice in Safe Mode
does not make any difference

###using other Packages
I tried downloading a appimage (the basic version, still package):
Version: 6.4.7.2
Build ID: 639b8ac485750d5696d7590a72ef1b496725cfb5
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: qt5;
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
and it works fine
I also installed from snap (sudo snap install libreoffice). After installing, I got the message “libreoffice 7.0.2.2 from Canonical✓ installed” and it works even slower than my “original” installation of libreoffice

###SAL_USE_VCLPLUGIN=gen libreoffice
Mmm some improvement here. The responsiveness is much better, although each time I select a column the state bar shows “loading document” twice. But in general it is a bit faster than normal operation. I have also tried “kde4”, “kde5”, “gtk” and “qt5” (and maybe 1-2 more I don’t recall now) instead of “gen” but it comes back to slowness. So the “best” performance of 7.0.X.X so far in all these tests was with SAL_USE_VCLPLUGIN=gen libreoffice
Is there something else I can do to follow this line of diagnosing?

It is really strange because all other software works very well and fast in my computer…
Thanks!

I find this with the snaps libre office, the scrolling is and operation is very slow in writer it is worse. I am on ubuntu 16.04 and the version of 5 in the repository works as expected. Will try the app image though!

So having 64 GB of RAM, 12 core CPU (24 threads) and a great Nvidia graphics card I need to use SAL_USE_VCLPLUGIN=gen libreoffice which makes the interface ugly to be able to type a three-page long document. The optimization is so borked. I would be really happy to help to diagnose the issue. Ubuntu 20.10, 7.0.4.2

I have the same problem. Big Ryzen 9 CPU, lots of RAM and nvidia GPU. Totally unusable without SAL_USE_VCLPLUGIN=gen libreoffice. Disabling the hardware acceleration and anti aliasing does not make a difference. Any ideas? Maybe it’s specific to the nvidia driver? ( NVIDIA Corporation TU106M [GeForce RTX 2070 Mobile / Max-Q Refresh], ArchLinux nvidia 460.56-2)

Also here on Ubuntu 18.04.5 with Intel® Xeon(R) CPU E3-1240 v6 @ 3.70GHz × 8, GeForce GTX 1060 6GB, 32GB RAM. Even with SAL_USE_VCLPLUGIN=gen libreoffice its not really good. Libreoffice 7.0.4.2

UPDATE: Fixed for me after update to 7.1.2.2! Running smooth again, even with multi pages view.