Calc app not responding

I am getting a “not responding” meggage frequently. I have the calc app open, and when I go to another location to copy a word or two to paste into a cell, I get “not responding” and a blue rotating circle every time I return to Calc. I have to wait several seconds for it to get ready to work before I can paste and continue. I just downloaded LibreOffice today, and I can see that it has the features I need, but if this delay is typical, I won’t be able to use this as an Excel replacement. Does anyone have any idea why it is doing this? Some details:

  • Windows 10, 64-bit
  • Surface Pro 7
  • LibreOffice
  • Only have Calc, Excel, Chrome Browser, and my Windows Explorer folders open when this is occurring (so that doesn’t seem like a lot of things to have open at once)

Update: This also occurs even when I leave Calc to view another document and return, even if I haven’t copied anything to paste.

If set, try to disable Skia in Tools -> Options -> LibreOffice -> View -> Category: Graphics Output -> Option: [ ] Use Skia for all rendering and check whether that fixes/mitigates your problem


If set, try to disable hardware acceleration in Tools -> Options -> LibreOffice -> View -> Category: Graphics Output -> Option: [ ] Use hardware acceleration and check whether that fixes/mitigates your problem

In addition you may also want to check Windows security settings (keys: Ransomware Protection, Controlled Folder Access … default settings are not friendly to non-MS software, to put it kindly)

Thanks for the ideas. I tried the first two, but neither helped. I looked at the security settings, but I couldn’t see anything that looked safe to disable (or that I could disable just for this app). Again, thanks for trying to help.

Maybe you need to add soffice.bin as a trusted program/allowed program in your third party anti virus. This page on installation might offer a little help

I have a similar if not identical problem. If I copy a cell in Calc then attempt to select another cell, I always get Libreoffice not responding. Have tried recreating profile, uninstalling/reinstalling Libreoffice, and disabling skia and hardware acceleration. Am at Window 11 Home Edition, Java 1.8, LibreOffice

Help, I copy cells all the time, this is crippling!


First steps to take before submitting a bug

I think you should ask your question as a new question as it is a different situation to the existing question