CALC: Auto recalc does not work.

I use my old ods file years ago. The formulas recalc does not work a few weeks ago.
If I press F2 to edit the formula and at the end of the formula I press a SPACE then ENTER it works.
One example:

C2 D2

3000 =C2/423

When I edit C2 and press ENTER, D2 cell shows wrong value.
But if I edit D2 and I press SPACE (so I modify the D2 VALUE ) Calc can calculate the good value.
F9 works but I think I should not have to use F9 all the time.

Which version do you use?

Did D2 show the formula or a (wrong) result before you entered editing mode?

You mention that you’re using an older file from years ago. LibreOffice intentionally does not recalculate older spreadsheets, because as formulas are updated from version to version or between different spreadsheet programs, the results can be different. Go to Tools – Options – LibreOffice Calc, under ‘Recalculation on file load’, change the two drop-downs, ‘Excel 2007 and newer’ and ‘ODF Spreadsheet (not saved by LibreOffice)’, to ‘Always recalculate’. Click Ok, close the spreadsheet and LibreOffice. Now open the file in LibreOffice and you should see that the formulas have recalculated.

Also go to Tools – Cell Contents and be sure that AutoCalculate is selected.

It worked for me, great thanks! Add: Restart the LibreOffice when it doesn’t auto recalculate after changing.

The location of where the final options are has changed. I don’t know which version it started with, but in 5.3:

  1. still go to Preferences: LibreOffice Calc or (guessing for windows) Tools: Options: LibreOffice Calc
  2. then Formula
  3. There you’ll find both Recalculation on File Load options mentioned above.

Dear Support,

Still having similar problem Version:
This is my case:
B10= number, data for these formula
C10= formula: =IF(IFERROR(B10,0),1,0)
D10= formula: =SUM(C8:C12)
E10= formula: =SUM(D8:D12)
And those cells copied to B1:B20
The result: ONLY the col C that changed by input or edit the cell in col B. NO changes in col D and com E, related option already been set.

I had this problem with a specific spreadsheet, and it was fixed by saving as a copy in xls format, then opening the xls in libreoffice and saving as .ods again. Maybe “save as a copy” would also work saving in .ods directly, but i didn’t tested it.

libreoffice calc had / has a problem with ‘shared formulas’ randomly blocking autocalculate since years, i think was the last ‘save’ version (it was without ‘shared formulas’).

the problem described by Budi B L is still in for linux x64 if switched to ‘threaded’ calculate mode, may be also in ‘CL’-mode, ‘unthreaded’ looks working correctly.

as the bug appears only randomly it’s often considered fixed while still there but not apparent …

‘hard-recalc’ (ctrl-shift-F9) fixes the erroneous results (in most cases) but cells may stay excluded from autocalculation and produce new faults lateron.

you may find work on it at, e.g. bug #123736.