Calc: can't set print range

I’ve tried all the solutions I’ve found online, but I still can’t set a print range. I’ve made sure that the sheet scaling is set to print by 1 page wide and 4 pages tall (the printout will fit in this). I’ve tried:

  • selecting the area I want to print then format:print range:define
  • format:print range:define then selecting the print area
  • both the above with format:print range:add instead of format:range:define

In all the above cases if I hit CMD-P the preview shows a few lines from the middle of the spreadsheet (not the area I’ve selected, but always the same lines), but if I use file:preview then it’s blank and says that there’s no print range set. If I do format:print range:edit then there are no print ranges set - all the fields are blank.

Is there some secret to setting a print range? It’s been a problem ever since I’ve used LibreOffce (i.e. not just this version - goes back at least 3 years) but I’ve been able to live with it by using screen shots, but now I’ve got a multi-page spreadsheet to print and screenshots don’t really work.

Mac Monterey with LO7.4.4.2

If you click on one of the non-printing cells and select Format > Cells then, in the dialogue that opens, select the tab Cell Protection, is the box Hide when printing ticked? If it is and you don’t want to hide anything then select the entire range or sheet and then untick that box.

It might be the same setting in the template you are using

Thanks Earnest. I’ve just checked and none of the cells are set to hide when printed. As far as I know I’m not using a template.

I tend to use Format > Print Range > Edit and use the Shrink icon at the right of the top field to select the range then click the similar icon to Expand again. You should see the range you have selected, e.g. $A$1:$K$356, make sure it is what you expect.

You can also set Rows to Repeat at the top of each page to aid the reader.

1 Like

In addition to @EarnestAl ,

Page and printer setup in Calc

I hope that can help a little.

Thanks, @EarnestAl . That works OK, but only if I type in the range manually. If I use the button to define the range with the mouse then it doesn’t work . So I’ve got a way to print - thanks - but I wonder why the other print range methods don’t work.

Thanks, but as I point out in the OP, the method in the manual doesn’t work. The link you sent says

Now you choose [Format ▸ Print Ranges ▸ Define]
Check again with File ▸ Print Preview.

When I define the range then check again with File:Print Preview there is a blank page with “No Print Range Set”.

Earnest’s method (above) File:Print Ranges:Edit works OK - but, so I can print now, but only if I type in the print range manually. It’s odd that the no other ways to define print ranges don’t work.

Would it be conceivable that an old print area still exists?
You can delete all print areas and create the desired print areas again.
Or test it in a new document with little data.
Or upload a reduced and anonymized document in which the problem is present here.
That way someone can look at it and examine.

Let’s do an experiment together.

  1. Create a new Calc file and fill cells A1:C3 with the value 1.
  2. Select the cell range A1:B2 and Menu / Format / Print Ranges / Define.
  3. Print preview. There should be 4 cells on the screen (with value 1).
  4. Menu / File / Print. There should be 4 cells on the screen (with a value of 1).

If different results are obtained in your experiment in steps 3 and/or 4, then save this file and upload it here. If possible, please show screenshots (steps 3, 4).

Thanks, Sokol, but I know what causes the problem - it’s if I have Autofilter set and have filtered at least one of the columns. In this case the only way to set a print range is via format:print ranges:edit. format:print:ranges:define doesn’t work and format:print ranges:add doesn’t work.

If I unfilter all the columns, but leave the Autofilter in place, the format:print ranges:define works as I’d expect it to - i.e lets me define the print range.

You have not written about the autofilter before.
Thus, I think the problem is solved. So?

It’s solved in the sense that I can now set a print range. I think that the fact that 2 of the three ways of setting print ranges using format:print ranges don’t work if a column is autofiltered isn’t the expected behaviour and it’s not the way Excel works. I’d call it a bug, but it could be a designed behaviour I suppose, although I can’t think why. I’ve marked my previous post as a solution just in case anyone else has the same problem

1 Like

It sounds like a bug, can you do a bug report? You would need to create a sample spreadsheet showing the issue. See How to Report Bugs in LibreOffice - The Document Foundation Wiki

I need another account to raise a bug report. I’ve already got an account for using LibreOffice so I don’t want another one. Feel free to raise a bug report if you want - I don’t mind.

Thanks everyone for the help.

If you don’t mind filing bugs then developers don’t mind fixing bugs either. Don’t expect anything to just magically happen. If it’s not worth to create a bugzilla account then it can’t be that annoying.

I’m not annoyed - I’ve got a workround. I don’t want anything to do with Bugzilla.