Calc cells shows only formula and not product/output


Since updating to (I think) LibreOffice 3.5.0 (and now 3.5.1) on Mac OS X 10.6.8, all my Calc spreadsheet formulas continue to work, but their cells no longer show the results! Instead, the cells show the formula. I tried copy a paste special with numbers only from the formula into another cell, and the formula’s output gets pasted.

This is very strange and frustrating, can anyone help with fixing this? Thanks!

You need to disable the checkbox in Options->LibreofficeCalc->View->Formula

@mmohrhard It worked, thanks! I don’t remember checking the box in the first place, though…

On Mac OS X 10.12.6, the mouse chant is Preferences->LibreOffice Calc->View->Formulas. That might help someone frantically searching for the Options button…

Hi, see your cells format. Maybe they are formated as Text. In this case, formulas doesn’t work. So, change it and try again.

Change it to what?

Worked for me, thanks. I even signed in to upvote it, but it’s impossible with novice karma < 5 :frowning:

Thanks, upvoting by comment!

Changing the formatting helped me! Thanks! (Can’t vote you up - not enough points…)

I am running Libreoffice Calc under Linux Mint 15 Cinnamon on a 4GB RAM Intel i3 machine. When “Show Formula” is checked, the formuala appears, but not the result. Unchecked, I see the result. As expected.


I also run LibreOffice for Windows in a Windows XP virtual machine. In this case, when Show Formula is checked, l get the result. When it is NOT checked, all I see is the formula.

Is this a bug or a feature?