LibreOffice Calc not computing functions (showing function, not output)

Hi Everyone,

I cannot get libre office calc to recognize functions. I am being shown the formula as it is typed, not the desired output.

I have tried Tools > Options > LibreOffice Calc > View > Formulas. Either checked or unchecked gives the same result.

Also, if I press Ctrl-F8, text remains black, numbers turn blue, but nothing turns green (another question told me that formulas would turn green).

below are identical questions whose solutions do nothing.

http://en.libreofficeforum.org/node/2353

First of all, make sure your formula starts with the = character. Try this formula to test:

=IF(TRUE();“HELLO”;"")

Normally you should see “HELLO” in the cell you pasted the formula into.

If not:

  1. Right-click the cell in which you pasted the formula and choose ‘format cells’.
  2. Select ‘number’ and then ‘standard’ or ‘default’ (depending on your language). Click ‘OK’.
  3. In the formula-bar (the bar on top where you can see your formula) click on the = button. The button will now turn into an Arrow. Click on the arrow.

Now you should see “HELLO”.

This is not working for me , it still shows the formula and not the solution.

Can you upload your spreadsheet?

You need to type a “space” between equal sign and the rest of formula. At least it worked for me

Adding the space after the equals worked for me as well. I’d call this a minor but irritating bug

I fail to see how that could be possible. Also, IMHO such behaviour was never submitted as bug. One should assume if that was a common behaviour it should had shown up as a bug report. If it happened only for specific function names then it may have been a translation error where the “word” of a function included a leading space. But then again the parser should had eaten that before… What UI language with translated function names were you using, if any?

I just got the same problem and the fix above worked for me as well
("Adding the space after the equals worked for me as well.)

Version: 7.0.2.2 (x64)
Build ID: 8349ace3c3162073abd90d81fd06dcfb6b36b994
CPU threads: 12; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: en-GB (en_GB); UI: en-GB
Calc: CL

@newchapmj1: If it is reproducible and also happens in 7.0.4 (which currently is the latest stable release you should upgrade to anyway) and also after resolving possible user profile corruption then please submit a detailed bug report also attaching a sample file with which the bug is reproducible for you.

Check that the cell were you type the formula in is not formatted as text.

I have a similar issue with a ODS where the formulas don’t work but what I have noticed is despite explicitly Ctrl+1 set Category: All, set Format: General, OK., it doesn’t change the format of the column from Text and formulas still don’t work.

Version: 7.0.4.2 (x64)
Build ID: dcf040e67528d9187c66b2379df5ea4407429775
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL

If you select a cell range that already has multiple different number formats assigned then invoking the number formatter displays General and selecting the General format will not change anything. You either need to temporarily set an explicit other format and after that invoke the number formatter dialog again on the same selection and set the General format, or remove all attribution on the selected cell range with Ctrl+M or context menu Clear Direct Formatting.

Note also that you have to re-enter a formula (editing the cell and appending and removing a blank is sufficient, or for a cell range with Find&Replace replacing = with = achieves the same) after the Text format was removed because the cell content is still text, not formula.

This has been fixed as of LibreOffice 6.4.4.2 space after = is no longer needed to enable evaluation of the formula.

It never was.

In my case (LibreOffice 6.4.4.2 on Linux Mint), it helped to reload the spreadsheet. Just click on menu File and hit Reload. You should see your formulas calculated, at least I managed to see them again. Nevertheless it is a bug that should be fixed.