Calc crashes working on large file

Hello LibreOffice community,

I am having trouble working on my spreadsheet in LibreOffice Calc. Once opened, most operations in Calc have a pronounced lag (scrolling, selecting all data with Ctrl+A, applying a Standard Filter), don’t make apparent changes (ascending/descending sorting of a column using expand selection), or crash the application (deleting multiple selected rows).

My file and system specs:

The workbook is a 4,294 KB .csv (I also tried working with a .ods copy) that contains one spreadsheet tab with text in less than 60,000 rows and exactly 4 columns. Every even row is blank. (I was trying to filter and delete these blank rows before Calc churned for 10 minutes and crashed.) Two of the columns contain strings between 4 and 12 characters, while one of the columns has strings that are admittedly long (many around 256 characters). However, this is not a particularly large nor demanding spreadsheet; I would expect any spreadsheet application in the last 18-20 years to handle it. Is this a normal threshold limit for Calc?

I am currently trying LibreOffice v4.4.3.2 (latest stable) and LibreOfficePortable v4.4.3.2 (latest stable) on Windows 7 SP-1 with latest Windows updates. The system uses an Intel i7-3770K CPU and 16 GB of DDR3 1600 MHz RAM.

I received the following error upon crash:
LibreOffice 4.4 Fatal Error - bad allocation.
While posting my message, I left the error dialogue open (the application crashed but did not yet close). About 5 minutes after the initial crash, I received another message: Visual C++ Runtime Error.

Any thoughts or comments are greatly appreciated. Thank you kindly in advance!

In my experience, Apache OpenOffice is much more stable when working with large files as compared to LibreOffice. Try.

I had a pretty similar problem as you have, and the solution was quiet simple: close Qlipper before opening Libreoffice.

That’s all. Hope it works for you.

Lubuntu 20.04
Libreoffice Versión:
Id. de compilación: 1:6.4.3-0ubuntu0.20.04.1
Subprocs. CPU: 2; SO: Linux 5.4; Repres. IU: predet.; VCL: qt5;
Configuración regional: es-AR (es_AR.UTF-8); Idioma de IU: es-ES
Calc: threaded

1 Like

Yep! Thanks kindly for you suggestion! I recently worked with relatively large files in LibreOffice, on Ubuntu 22.04 and have no problem at all. Next I switched to Mint 21.1, and suddenly when opened 46000 line csv file I had a big trouble. When I select whole table after that LibreOffice Calc immediately shuts down with a reason “Due to en error, libreoffice is crashed” blah blah blah. Not much useful info in the message. I get an idea it really had to be connected to mouse clipboard. Tried multiple google requests with no luck. And then tried crash on a large file. And here is you brilliant answer! Very grateful for which am I.
But it ain’t Qlipper for me, no. It was CopyQ! I recently installed it, and if it has Clipboard Storing function active, LibreOffice Calc fails on large selections. But if you disable Clipboard Storing, LibreOffice work alright.
So looks like it is a good advice to check your Clipboard software, in case of LibreOffice fails on selection.