CALC: CTRL+SHIFT+; deletes cells but does not enter the time

Build ID: 1:5.0.3~rc2-0ubuntu1~trusty2
Locale: en-US (en_US.UTF-8)

CTRL+SHIFT+; deletes cells but does not enter the time

I checked the customization of the keyboard:
CTRL+SHIFT+; is allocated to enter the date
CTRL± is allocated to delete cells

How can I get LibO Calc to enter the time?
Is this bug in this LibO version?

Thanks for your help1

Cannot confirm with :

Build-ID: 1:5.3.0~rc3-0ubuntu1~xenial1.1
Gebietsschema: de-DE (de_DE.UTF-8)   OS LM17.3 Cinnamon

Bug exist also in

Build ID: 686f202eff87ef707079aeb7f485847613344eb7
CPU Threads: 4; OS Version: Linux 3.19; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: en-US (en_US.UTF-8); Calc: group

See EDIT of my answer below.

You may remember that I am on silly Win 10, and that I mostly use very fresh versions.
I cannot test with V5.0.3 (and, of course, not on Ubuntu), but I preserved a V5.0.2 Portable. Just tried it and can confirm same behaviour: Key assigned but not working. I also cannot think of an extension installed for the old version probably overlaying the shortcut assignment.

With V5.3.0.3 I see the same state and behaviour, except that I have installed ‘Compose Special Characters’ for this version (rarely use it), and this might probably interfere in a hidden way. Did you look for related bug reports already? I didn’t find the needle with a finger in the haystack.

Regards und alles Gute

Sorry. Missed to mention that I did not get an effect like “delete cell” or “clear cell” with either version.
(Edit 2:)
The functionality is present.
I suppose @ROSt53 to use like myself a keyboard with German pysical layout. There may be a conflict only afflicting users with a German keyboard layout. Shift+Ctrl+, and Shift+Ctrl+; are both offered when customising the keyboard to create shortcuts. These combinations are, however, not physically different under the mentioned layout as there Shift+, = ; holds true. I get the expected behaviour if I assign ‘Insert Current Time’ from category ‘Insert’ to the alternative combination Ctrl+Shift+, . This with V5.3.1.2 under Win 10.

Choose your version from Index of /libreoffice/old and then portable if it exists.

@rautamiekka: Yes. I have 14 versions of LibO and AOO here for testing (and á StarOffice 5.2 from 2000). I just didn’t want to download another (only different by third digit) version. Thanks nonetheless.

Thanks everybody for comments.

I intend to install a newer version of LibO parallel to the - a bit old - version from the Linux Mint / Ubuntu repository. For The time being I have to live with the bug.


I installed now LIbO parallel to the and observe exactly the same problem.

The exact version is:

    Build ID: 686f202eff87ef707079aeb7f485847613344eb7
    CPU Threads: 4; OS Version: Linux 3.19; UI Render: default; VCL: kde4; Layout Engine: new; 
    Locale: en-US (en_US.UTF-8); Calc: group

I am using a Japanese keyboard, which is concerning “Crtl+shift+;” the same as the US keyboard.

In Windows versions up to 5.3.x it “ctrl+shift+;” perfectly inserted the time. I used exactly the same keyboard.

What can cause the bug?
Difference to @karolus:

  • US version - German version
  • KDE version - Cinnamon version

Can a macro be written which enters time in a cell using the same key combination?

Thanks for comments and help.

EDIT 170926

Thanks for all your comments.

While looking for the “comma” instead of “semi-colon” possibility I found that in
Tools > customize > functions > category = insert has no “Time” item in Function table but only “Date” and others.


Tools > customize > Shortcut keys shows the “Insert Time” combined with “crtl+shift+;”


I installed also LibO and see exactly the same situation.

Is this a bug in LibO, LibO, anmd LibO Linux version?
Is there a way to get “Time” in the Function table?
Can it be related to the KDE version of LM 17.3?

What is your understanding of this?
Ways to solutions?

(edit: activated screenshots)

@ROSt53 Using:

Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group

on Mint 18.2 I have no problem with the Ctrl+Shift+; inserting current time. Time permitting will try other versions.

Had this version on Mint 18.2 KDE:

Build ID: f82d347ccc0be322489bf7da61d7e4ad13fe2ff3
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: en-US (en_US.UTF-8); Calc: group

and again it works without a problem. The difference seen is the Kernel version. Could this be the cause?

I believe it is also worth mentioning, OpenGL is off on all my installs. Menu Tools->Options, LibreOffice->View.
A last check was done on Xubuntu 16.04, LO v5.4.1.2, Kernel 4.4.x and again all worked.

Can a macro be written

see my extension DateTime2 - old, but still working

@Ratslinger - OpenGL is off on both versions

@komma4 - I installed your extension but still have to find out how I can start and do changes from German to English version. Unfortunately I did not find an explanation on how to modify and how to run your attractive extension. Do you have an hint? Guideline? etc?

Now at least in Spanish works with ‘,’ instead ‘;’ maybe it was changed in other languages.

The issue is they were assigned to characters ‘;’ that are the shift of the key on some languages like Spanish.

Maybe it should be changed for all languages with ‘;’ as shift key.

See Shortcuts ctrl+; and ctrl+shift+; does not work in ru/es/pt/fi keyboard layouts

Problem is that on an English keyboard it is Ctrl+; and Ctrl+: for which for the latter one has to hit Shift+Ctrl+; and users don’t imply that : is actually Shift+; so the description uses Shift+Ctrl+;

Other layouts (have to) use other key assignments, things may be easier or more complicated to describe for other languages’ keyboard layouts, and sometimes help/description isn’t aligned with reality.