Calc custom keyboard shortcuts not working on

I am running Ubuntu 14.04 LTS 64 bit with LO (Version: Build ID: 1:5.2.0~rc4-0ubuntu1~trusty2 CPU Threads: 4; OS Version: Linux 3.19; UI Render: default; Locale: en-US (en_US.UTF-8))

I have tried to assign with Tools->Customize->Keyboard various CTRL and ALT unassigned keys to “insert date”. The key assignment always looks correct.

Use CTRL 8 for example.

However, this NEVER performs anything. I select a cell and press the keyboard shortcut combo CTLR + 8 simultaneously and not a thing happens. Other assignments act the same.

I have searched a lot on this topic and see a number of bugs back in 2013 but nothing new.

any help would be greatly appreciated


Working for me on windows 8.1, LO x64.

After assigning hotkey, if you save and restart LO, does the assignment still show correctly.

Make sure your macro is running correctly from Basic IDE. You could also add breakpoint at beginning of your macro and see if the hotkey is starting the macro execution.

Did you set the hotkey to save in LibreOffice or just in the document that was active at the time you set the hotkey?

I can tell you what worked for me:

Tools (menu).

Customize (sub menu)

Keyboard (tab)

Move through the listbox until you see the key combination you wish to set

Highlight that key combination

Select “Modify” button on the right side of the dialog box

Now, go to Category list box, find the correct category (highlight it)

Go to Function list box, find the correct function to assign (highlight it)

Click OK button on the bottom of the dialog box

On the Insert Date function appears to be extremely buggy. The Ctrl-9 hotkey I used works fine for other things.

Perhaps the best way around this would be to record a macro to insert a Date function. I just did so with =Today(). Assigning it to Ctrl-9 works flawlessly. The Today function does update itself, however, so a plain text insert might be better, or maybe there’s another way.