calc doesn't adjust cells to the size of the text even if autoadjust is selected

My Version is I use Windows 10. Thank you very much in advance.

Where did you select “autoadjust”?

I did it this way: Format>Cell>Alignment. Anyway, I’ve found this happens only with cells that have been merged with some other ones, and I guess that’s got something to do with it. In new sheets, cells that have not been merged work fine.

I stiil do not understand because I cannot find an option ‘Autoadjust’ or a property offering this as a possible value in > ‘Format’ > ‘Cells…’ > tab ‘Alignment’.
There is an option ‘Wrap text automatically’. Is this what you mean?