Calc : entering a number changes the font from standard face to face=1

My default font for spreadsaheets is Calibri.
However, when I enter a number, e.g. 2, it changes to Caibriface=1 and the 2 becomes supercripted.
I’m sure it isn’t a bug ort anything, just a setting that is awry, but I cannot find that setting.
Any any ideas where I should look?

Thank you,

Calibriface=1 is odd, normally if there were a variation in the font it would read something like Calibri:sups for superscript.

You need to edit the template that you set as default. So click File > Templates > Manage templates, in the dialog find your template with the green tick (your default), right-click it and select Edit.

The template will open. Open the sidebar and click on styles icon, select the icon Cell styles, right-click Default and select Modify.

In the dialog that opens,

  1. Select the Numbers tab, under Category select Number and under Format select General
  2. Select the Fonts tab, select Calibri from the list, or delete anything after the letters Calibri, or in features button, untick all the boxes particularly ordinal and superscript. click OK. Save and close.

If you still have problems, it would be best to recreate your template using LibreOffice rather then re-using an Excel template.

That worked perfectly - thank you very much! The template had calibri with the extra letters, and replacing it by clicking on the font did the job. No feature boxes were checked.

Thanks again!