Calc - File created from Template - Sheet2 differs from Sheet1

LibreOffice - Calc Module
Windows 8.1

I have set up a Calc Template file with just the one sheet. The font is Verdana and the font size is 7. I have changed the row height to 35.

If I open a new file using this template, Sheet1 is fine. But if I create Sheet2, the line spacing on the new sheet is 45, not 35.

Am I doing something wrong?

Request: I’m not a techy, so please respond at kindergarten level!

See Calc user created default template only affects Sheet1

Thanks for your input Lupp. Have looked at the link. I can see how that would help in the case specified there. But as far as I can see, setting the cell format doesn’t allow me to set a row height. For me Sheet2 has the same Font style and Font size as Sheet1, ie Verdana 7 - which is what I want. But not the row height I want.

As a work around, I tried to set up the template with two identical sheets (Sheet1 and Sheet2) with the required row height, but when I open a file based on that template, it ignores Sheet2 from the template entirely, and only shows Sheet1. Which is disappointing!

Sorry! I didn’t read thourougly enough. However, I cannot verify your statement concerning your workaround. I created a template with 3 sheets, 2 of which were set to a reduced line height, and I got all the three sheets with their respective settings instantiating a new document from the template. This with v4.3.5.1 under Win 8.1.

Rechecked behavior on v4.2.6.3. No change. Updated LibreOffice to v4.3.5.2 (current release). No change. Checked in File/Properties that new file was using the expected template. It was. But then I tried switching the template default to another file, and then switching it back again. Now I’m getting both of my template sheets with correct row height in my new file. This is now an acceptable workaround. Thanks a lot for the help you have given me and others. Much appreciated.