Calc Files Won't Open

Hello all. I was working this morning, swapping between existing Writer and Calc files. Was having no issues.
I then tried to open a new Calc file, but it would freeze up, read Not Responding, and then finally open after about a minute of freeze time. This is now happening with all Calc files (of which I have many). I backed up my user profile, reset to a new user profile, and then restored my old settings. Now, a new Calc file will open without issue, but the same problem persists with all saved Calc files. Even when I open a new file, name it and save it, it will not open without freezing for at least a minute. Any suggestions?

1 Like

Let me also add that when I started having this issue, the first thing I did was install the latest version of LibreOffice, hoping that it may fix the issue. Then I went through the user profile reset protocol. The files will not open without “not responding” in Safe Mode either.

Welcome @brotherbear!
Could it be that a path in Tools > Options > LibreOffice > Paths is on a disconnected network?
Could it be that a printer defined in File > Printer Settings is offline?

Thanks for the response. I looked into both of these matters, but nothing seems to be out of place. I reset the Paths, but it didn’t cause any change.

What is strange is that it will open a new Calc sheet instantly, but if I simply save the blank sheet as a test, it will still freeze and become unresponsive when I try and open it. This is only affecting Calc sheets.

Any ideas from the technically gifted out there?

Please paste here the version information from Help | About LibreOffice; use the copy icon to copy the text to your clipboard.

1 Like

Version: (X86_64) / LibreOffice Community
Build ID: db4def46b0453cc22e2d0305797cf981b68ef5ac
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

Well it’s been over a week, and sadly I still haven’t been able to find a solution to this problem. I can’t find anyone else running into the same issue with Calc files anywhere online. LibreOffice has never given me any trouble, but this issue has totally destroyed its functionality for work. My goal here is to not have to swap to MOffice, but I just cant work with the unresponsive calc files. Any final thoughts or suggestions?

This is the most likely problem; tdf#42673 is still unresolved.
You should try to:

  1. Change your system default printer (e.g., to some virtual printer, like a PDF printer);
  2. In LibreOffice options, disable loading printer settings from the document.
1 Like

Thank you for the response. I did try unchecking this box as per Steph1’s guidance, but it didn’t have an effect on the load time.
What is the function of soffice.bin? When it freezes and I bring up the task manager, that is the file that is not responding. I thought maybe it has something only to do with Calc files.

soffice.bin is LibreOffice main process. I guess that you are asking because you are accustomed to processes started from EXE files; yes, LibreOffice’s soffice.exe is not the real program, just a launcher, that starts the BIN.

Thank you for the explanation Mike

OK, I think the printer settings may have been the problem after all! After unchecking the box, nothing changed. It wasn’t until I allowed the computer to turn off overnight, and once powered back it worked! I should have known to restart after a setting change like that. But, either way I’m a happy camper. Thank you all for your input!