Calc ignores my cell formatting

See picture. I input “08/04/22”, but Calc keeps changing it to “04/08/22”.

What is your Date acceptance patterns? Look at menu Tools - Options - Language Settings - Languages. Change there M/D/Y for D/M/Y.

This works, thanks.

Switch to language English (UK) or any other non-US langauge.

Choices of countries here

The choices of countries are in the cell formatting dialog. There you can specify the locale for sheet cells (* misleadingly labeled “Language”).
The number format locale of cell style “Default” does the trick for a document.
The number format locale of cell style “Default” in your default template does the trick for all spreadsheets.
The number format locale under Tools>Options>LanguageSetting>Locale does the trick for the entire office suite.

FTR: tdf#138748

1 Like