Calc importing csv error even after re-install

Some days ago i open an old file .xls , which probably corrupt or i’m not sure what happen to that old file.
So there was importing wizard as you usually open any CSV files.
It was open and there were strange symbols or content which is not my old data.
Forget about the data, now every time I open a CSV file, I get the same error.
I can generate CSV file normally (with Calc), but every time i open any CSV file, I get the same error as if it to open that .xls file (the csv file is not broken, as I can open it with editor), but the Calc shows that strange content a lot of symbol (i don’t know what is that).
Frustrating with this problem, I deleted my LO from my ubuntu (apt purge, purge everything, also purge the LO-core),
I installed it again from apt. I did this twice.
The problem remains.
Now I cannot open any CSV file with Calc.

Do you have any idea what to do?

OS: Ubuntu 20.04
LO: originally from the os, and i re-install the one from APT (v6.xx)

Please note If a problem is caused by a corrupt user profile, reinstalling LibreOffice won’t help at all, since this action won’t touch the user profile. Therefore: Before reinstalling check whether the user profile might be the cause of a problem.

To test whether LibreOffice user profile is causing the issue:

  • Start LibreOffice
  • Restart in Safe Mode using Help → Restart in Safe Mode and confirm the restart using button: Restart
  • Click button Continue in Safe Mode
  • Perform the procedure showing the problem and check whether the problem is gone (If you need to open a file, use File → Open - do not use some other procedure)

**Ref.:** [LibreOffice User Profile](
Please provide a feedback about such user profile test using *add a comment* function.

Thanks for the fast suggestion! Really appreciate it! I will read about user profile and try your suggestion.

In addition, check which charset is set for the imported CSV (the topmost field in the Import Text form) - perhaps the reason is an incorrect encoding.

@anon73440385, the problem was solved when I use Safe-mode. I confirm the problem re-appears when i use normal mode. I will try to reset the user profile (I’m learning how to do it).
@JohnSUN, the charset in the original was Unicode (UTF-16), in safe-mode was Unicode (UTF-8).
When i changed the charset in normal mode to UTF-8, it works well!
So my conclusion is that somehow when I open that old xls file, the charset in the LO import wizard was set to UTF-16 and was safe into LO user profile.
In this case, now it’s working, should I take care of the user profile?
Thank you to both of you!!!

By the way, how to close this Question if it was solved by comments only?

@teko_ippt You solved this problem yourself, @anon73440385 and I were just showing the way. So you(!) should write the answer - a screenshot (small) “how it was”, a description of the actions and a screenshot of “how it now”.

Based on suggestion @anon73440385 and @JohnSUN.

I’ve found the default charset somehow was modified into UTF-16.
Every time I use Text import wizard it looks like this:

image description

It is a good way to check if something was modified (accidentally maybe), by using the Safe-mode as written in above comments. It is important that the user profile will not be set to default even you re-install the LO.
I see that the default charset is UTF-8 in the safe-mode.
Afterwards in normal mode I set the charset back to UTF-8, everything backs to normal, the default charset also automatically set to UTF-8.

image description

Thank you, @anon73440385 and @JohnSUN!

Oh… I don’t have 20 points to accept my own answer…:smiley:
Probably wait until next year…