Calc introduces unbreakable, non-existing links in my sheet

I have a Calc .ods-workbook that I use about once a week. Since about two weeks ago I get a pop-up that asks whether I want to update links in the workbook. It turns out I now have a few unbreakable, non-existing links in my sheet. Help is greatly appreciated. Here are the specifics:

The problem

  1. When I open the workbook I get the message: “This file contains links to other files. Should they be updated?” If I press No, the dialog disappears. If i press Yes I get the message: “The following external file could not be loaded. Data linked from this file did not get updated.”
  2. I go to Edit > Links and notice that two non-existing links are suddenly present in the workbook: file:///home/stijn/S and file:///home/stijn/L. I have not conciously made this links, they just appeared. The flies mentioned in the links do not and have (probably) never existed. Quite frankly, they are not even complete file paths.
  3. When I close the workbook and re-open I get the same message every single time.

Solutions I have tried that did not work

I Googled for solutions and found quite a few on how to find and break links, but none work for me:

  1. If I use Modify or Break link from the Edit > Links menu, the same links will just be magically there after saving and re-opening the file.
  2. If I try to use Find or Navigator to find where the file paths are linked, I can not find them anywhere.
  3. If I save the file to another format using LibreOffice (.xlsx for example), then the problem is gone in the .xlsx but if I then resave the links will be back in LO.
  4. If I open the file in MS Excel the links are gone, even when I save back to .ods and open in LO. However, a lot of my formatting and calculations are also screwed up.
  5. The only temporary workaround is to go to Tools > Options > Calc > General and disabling updating of links completely. However, this is poor man’s solution: it affects all my workbooks while the bogus links are still in my file

If there is anyone with a suggestion on how to fix it, that will be greatly appreciated!

I have the same main problem, with differences: When I click Yes on the dialog that asks me to update the links, the dialog just disappears and the Edit > Links menu is greyed out (there are no links, obviously).

I have had this problem, including just now, on calc build 1:5.1.6~rc2-0ubuntu1~xenial2. I fixed it by turning off change tracking:

  1. backup file (to save change history, and just-in-case)
  2. deselect Edit \ Track Changes \ Record Changes
  3. save
  4. reopen

You could probably add
2.5) reselect Edit \ Track Changes \ Record Changes


for the record this fix doesn’t work with LO Version: Build ID: 420m0(Build:2) which is the default for those of us using Ubuntu 14.04LTS. Edit offers: ‘Changes’>‘Record’ [tick or not]. ‘Record’ was not set in the 1st place but the non-existent non-removable links persist [eg: file:///home/home/c]

have a quite similar issue, probably pested / infected a file with some picture data from my bank by copying data from there into a calc sheet, now i have three ‘xhtml-filler’ ‘images’ under ‘edit’ ‘link to external files’. they don’t ask for update or appear in any other way, but i can see them in the content.xml file and under edit-links to external … i can ‘break’ them there, then they are gone for the session, but reappear after a save-load cycle.

as i experience crashes with such files in a new calc version i’d like to rule out that / if that’s somehow related, for that purpose i’d like to be able to get rid of the links. anybody an idea?