Calc is not saving changes

I am using Version: (x64) w/ Windows 7, I am making formula changes to my spreadsheet which work while the sheet is open but when I save the spreadsheet and reopen it all the formulas revert back to the original values. What am I doing wrong and/or what am I missing? The spreadsheet was originally created with an older ver of calc.


Not sure, but I would try “save as”, renaming it. Your original file will still be there, just make sure what folder there saved in, and there names. Then reopen newly named file, change should be there.

I have had this fault myself and find that if the SAVE button doesn’t work (ie the * remains visible after pressing it), click on FILE tab and then scroll down the listing to “save”. Press this and it saves the page as normal. Subsequent SAVE button presses then seem to work as expected. But by all means use “save as” to a new page if this gives you more confidence!

I ran into the same issue today. I opened an .ods file that I worked on yesterday and found that one of the tabs had old data instead of the formulas I had setup with external links. I tried “save as” and “save a copy”, neither worked – when opening the new file, I briefly see a flash of the correct content until external links are updated, and then the old incorrect content is restored.

The workaround I found was to create a new sheet, copy the formatting to it, recreate the formulas there, confirm it survives closing and reopening the file, and then delete the old sheet.

LibreOffice version (x64).