Calc lagging

I’m experiencing Libreoffice Calc slowing down when working with large cells.

My file in libreoffice calc is a little bit worked out, with more than 10 spreadsheets, with formulas and automatic formatting. Not too complex, but with some details.

In one of the spreadsheets, I have large cells, almost 20, with more than 10 lines in each cell.

In this spreadsheet, libreoffice calc becomes too lazy. When I click one of this big cells, it takes almost 10 seconds to select it.

When I close and reopen it, it becomes fast again, but just for some time. After some use, it’s slows down again.

I have the costume to suspend my computer with my spreadsheet opened. The problem can be related to suspend/awake process, but I don’t have any evidence in this sense.

I have tried some solutions:

  • Reinstalled libreoffice from Ubuntu Repository
  • Checked my video card instalation (somebody said that could be lack of OpenGL support)
  • Installed last version from ppa:libreoffice/ppa

None of those solved it.

My system details are:

  • Ubuntu 16.04 LTS
  • Libreoffice Version:

I too have Calc lag. Some previous versions of libreoffice were fine, some had lag. The latest version has SERIOUS lag. I noticed it immediately after installing. I use the latest Windows and have a fast graphics card. It is a problem with the software. On earlier versions the problem was with changing fonts. Now I can barely even scroll up, down, left, right with my keyboard arrows.

pls. check two points:

  • are you using comments inside this file, afaik they are the source of different unresolved performance problems since years,

  • regarding the delay before lazyness occurs: check if ‘save AutoRecovery information’ is on (tools - options - load/save - general), and if the time set there meets the delay from either opening the file or first edit in it to the start of slowyness. the first autosave after the first edit definitively triggers an ‘enhancement on impact’ on my ‘performance problems with comments’ by a factor of ~4.

just a test: try reformatting the big cells, especially avoid any manual formatting in them - calc is not writer - e.g. copy the text from the formula bar and insert it into the cell with shift-ctrl-v - choosing ‘unformatted text’.

good luck

I have the same issue, Cals starts OK but after some time it become very unresponsive.
Unable to work with data at all

that’s not an answer, i think it should be placed in a comment …

check my comment on the case, may be it helps