Calc: Loading native ods file is very slow / hanging

Hi, there are similar issues here, but they are about old versions on libre, so creating new one. This reddit thread exactly depicts there is a problem: Libre calc is loading native ods files very slowly (not everytime, randomly), but loads the same xlsx file instantly.

Steps to reproduce:

  1. Close all libre apps;
  2. Win + R, execute this: explorer "%appdata%\LibreOffice\4"
  3. Rename “user” folder. This will make your libre installation fresh (so no plugins or user settings can be blamed for);
  4. Launch calc, then close (so new user folder will be created;
  5. Open these two files with calc: their contents is only one line of text, created by libre calc before. Attaching files here: Untitled 1.ods, Untitled 1.xlsx
  6. Repeat file closure / reopening for ods file, and for xlsx;
  7. See the difference, when ods file loading hangs for several seconds (see video, bug is seen in 10");

See screencast:

In real world - loading ods is painfully slow, some libre caching issues? It seems that all ods files are loaded slowly in realworld, but we can notice, that about every 2nd load is faulty…

Windows security settings are completely off (I believe :)): Controlled folder access, realtime scanning, C:, D: *.ods, scalc, soffice are added to exclusion list.

Anyone has a working workaround (not one from LO v4.x? :))

Version: (x64) / LibreOffice Community
Build ID: 53d68d29d90fd16448721a60aad68c28ff0809f5
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL

Edit (the solution):
See @anon73440385 comment below, it points to the cause of the problem (issue tracker).

After reading tracker information, and trying on my system:
Does not work:

  1. Uncheck checkbox: Tools → Options → Load/Save → General → “Load printer settings with the document” (seems does not do anything);
  2. Open ods with 7zip and remove printer-related tags from config.xml (did not help for me);

What worked:

  1. Go to windows printer settings → Make any “Virtual” printer as system default. It can be “Microsoft XPS Document writer”, or PDFCreator (in my case). Now calc loads ods files at the same speed as xlsx files.

All credits go to @anon73440385 and users in issue tracker.

The following may sound weird to you - anyway: Do you have a network attached printer, which is off most of the time? Turn it on (or completely disable network on WIndows) and check load time of .ods files ( see also tdf#42673 - With disconnected network printers, Calc hangs opening some files waiting on the Windows print spooler)

@anon73440385, thank you very much, your answer is correct, I will edit post with workaround, which worked for me. I have seen that issue, but it was started in LO v3, so I skipped that ancient bug :smiley:

@eddy_lt - please add your What worked as an “Answer” here. It is a very valuable solution/workaround for all affected users.

Go to Windows printer settings → Make any “Virtual” printer as system default. It can be “Microsoft XPS Document writer”, or PDFCreator (in my case). Now calc loads ods files at the same speed as xlsx files.

See “Edit section” in main question area for more details - this is a copy-pasted info from main question section

Good morning from SA. I had a similar problem with Calc on Windows 11. It started about 2 years ago where I had to switch off the HP printer so that the file could open quicker. It eventually went away with an Windows update. Just bought a new printer and the issue surfaced again. This time the printer had to be on. Found that in both instances it was a Microsoft default printer driver. In the 1st instance windows updated the default driver to a HP driver and the issue went away. In the second instance I forced the Canon driver and the issue disappeared immediately. Trust this can help some who still have the issue.

Yes, thank you very much. Changed from MS driver to Brother driver and problem solved!