Calc missing transpose option

I am trying to transpose horizontal cell data to vertical columns.
I select the row data, click cut, click on new cell, click paste special.
The screen has one selection of “unformatted text”, I click OK and it pastes in rows.
I have no “paste all” or “transpose” options so cannot perform the transpose I need.

Thanks in advance for any help.

Which OS , which LO version? I tried to reproduce this with Ubuntu 12.04 and LO 3.5.4, but the only way to get that selection dialogue after “Paste Special” is using the the “Paste Special” functionality of Writer, not Calc. If the problem persists: Could you create a screencast …

… of how you proceed to reproduce this behaviour?

You must be working in a plain table in Writer. Paste Special has a Transpose setting in Calc.

Thank you for the responses. This behavior could not be replicated after a reboot.