Calc rendering producing unreadable display

I have been using Calc for two years on an iMAC. Suddenly rendering does not work properly resulting in rubbish displayed, but cell updates correct. Problem started after update to OS X 10.11.4. Same effect with Libre Office, and 5.1.3. Same problem with large and tiny spreadsheets with no complicated content.

Input data to cell and tab to next cell sometimes produces no display of data, but data is there.

Panning and scrolling can result in cells displaying data that is not there, or displaying overplayed data.

Closing file and then opening it restores the correct display.

The problem is to do with the display of cell content, not the underlying operation of the spreadsheet data

Cal is now unusable - Help please!

Please test disabling OpenGL.

Menu/Tools/Options/LibreOffice/View - Graphics output - Use OpenGL for all rendering.

Under Graphics Output, “Use OpenGL for all rendering” is disabled. The only function active is “Use anti-aliasing”.

I will experiment with different Graphics Output setting and report back.

I have tried all the available options for Graphics Output and get the same result for every one.

Problem persists and is making Calc unusable, even for very small and simple spreadsheets.

Please try resetting the user profile, sometimes solves strange issues.
Usually it’s enough renaming/deleting the file “user/registrymodifications.xcu”, it affects all the options in Menu/Edit/Preferences, and the files “user/basic/dialog.xlc” and “scrip.xlc” are overwritten, additionally custom colors in “user/config/standard.soc” are lost.

This menu on my PC says “OpenCl” (Ubuntu 18.10). Anway that’s not a fix to my problem. Every spreadsheed displays blank cells. I can see the data. Display is blank. Even CSV files. Inside the CSV there is no formatting information, this is spooky.

OpenCL it’s a different matter related on how calc does the calculations not the visualization.