CALC Saving my TSV file as a CSV without asking

Create a tab-separated file saved as test.txt.
Open in text editor and save:

1	2	3	4
This	is	a	test

(Those are tabs)

  1. Open it with Libreoffice Calc
  2. Click “Save”
  3. Libreoffice asks “Are you sure you don’t want to save as ODS?” or like
  4. Click “Use text csv format”

Open test.txt file in Text editor:

1,2,3,4
This,is,a,test

This is UNACCEPTABLE behavior that I would like to know how to stop. The file was a TSV, I did not specify to change it into a CSV. Libreoffice should KEEP my original format setting.

Note: Previous versions did (I’m pretty sure) since this is part of a workflow I’ve been using for years (since before the OO / LO schism)

  • OS: Ubuntu 16.04
  • LO: 5.1.4.2

Already answered here: How to generate Calc tab delimited output?