calc searches NFS even when the doc is on a local disk?

I have one of these small NFS server applicances (Dlink), which go to sleep after a while and wake up when an application accesses the filesystem; I have it mounted on a linux desktop. It takes up a minute to wake up, and I am painfully aware of this, because every time calc decides to autosave, the NFS drive spends a minute spinning up, and during that time calc is unresponsive.

And the absurd things is - this happens even when I only work on files on a local drive. Is there a way to stop it from happening? I mean, if I work on a spreadsheet on the NFS drive, fair enough, but I work locally for a reason (this reason, in fact).

Menu Tools → Options → LibreOffice → Paths

Highlight the path for backups and click on Edit. Change it to somewhere on your local drive (maybe create a new folder for your backups). Check that nothing else is going to your NFS server too.

Just checked - all paths point to my local disk. It also happens when I open the file dialog or save my document; it is as if it decides to have a (not so) quick look at all the mounted disks, just in case I want to look there.

Are you using automount daemon on linux ? If yes, I’d assume that this is not a libreoffice problem, but the libraries used for filesystemn dialog and such things. Another idea might be to look in your “Recent Documents” list, which might still contain paths to your NFS paths.

That’s very interesting and I can’t explain it. I hope someone else here can help. It might help to know what operating system you use and which version of LO you have. The configuration of your NFS might be a factor too. See the insightful comment above by @anon73440385.