Calc slow to open any spreadsheet - how to troubleshoot?

Calc has suddenly started to take up to a minute to open a spreadsheet. It doesn’t matter what’s on the spreadsheet - meaning I can create a dummy spreadsheet with the word “test” on it and it still takes a long time to open. But if I keep liberoffice open and close the spreadsheet and reopen it, then it opens quickly.

Libreoffice Text documents aren’t affected. They open instantly. And again if I reopen any spreadsheet, it opens instantly. It’s just the first instance of opening a spreadsheet that takes a long time.

I wasn’t sure if it was because I was on an older version of Libreoffice so I just updated to the most recent. But I still have the problem.

It seems that Libreoffice calc is loading something in the background. Any ideas/suggestions would be most helpful. Thanks.

This information might be useful:
Version: (x64) / LibreOffice Community
Build ID: e1f30c802c3269a1d052614453f260e49458c82c
CPU threads: 12; OS: Windows 10.0 Build 19044; UI render: Skia/Vulkan; VCL: win
Locale: en-GB (en_GB); UI: en-GB
Calc: threaded

I checked another PC that I have and there’s no problem with calc on that pc. So, it’s just this laptop that has suddenly started having a problem opening spreadsheets. Again,the first spreadsheet I try to open Calc goes into “Not responding” mode for about a minute and then it opens the sheet.

I tried starting in safe mode. That didn’t solve it. I then deleted the Libreoffice folder in %appdata% and that didn’t help.

Somewhere there’s a conflict on this installation that I need to troubleshoot.

Any ideas would be most appreciated as the delay in opening the first spreadsheet is a real nuisance.


Bit of an update - I completely uninstalled and then reinstalled LO 7.1.8 but I still have the issue of Calc taking a long time to open the first spreadsheet. It’s a fast computer with 32GB RAM so it’s not a resource issue. Any troubleshooting advice would be most appreciated.

Just check to make sure that you haven’t got it checking the printer before it does anything. Click Tools > Options > LibreOffice Calc > General and untick Use printer metrics for text formatting.

While you are in the same place just check that under Update links when opening that you have ticked On request.

@EarnestAl Thanks very much for the assistance. I have verified that both options are not selected. But I still have the issue. Opening Writer documents is not a problem. But when I open even a simple spreadsheet with no forumulas, it takes a long time to open. Reopening it or any other spreadsheet is instant. It’s just the first spreadsheet. I’ve looked in the Event Viewer and I see no errors. I’ve even repaired the LO installation. It really seems like something slows down the load of the first spreadsheet. Safe mode doesn’t help. And I’m not using any fancy anti-virus - just Microsoft. Thanks again.

It sounds like either

  • LibreOffice is attempting to access a network resource, hence printer check. Maybe OneDrive synchronisation interfering?
  • the security software is checking access or the file before releasing it

@EarnestAl Thank you very much for your assistance. I’m really at a loss as to what was going on because “just like that” the problem went away. I’m completely clueless as it was an issue one minute and then suddenly it was gone. But thank you again for your help - much appreciated.

It could be that this bug around disconnected printers is the cause.

Try setting “Microsoft Print to PDF” as the default printer because this one is network independent and always available.

(Source of the fix)

Many thanks for this. Your suggestion seems to have done the trick. Thanks again!

1 Like