Calc - The accuracy of the calculation?

OO Calc v5.1.0.3
The accuracy of the calculation?! How to configure so that would be considered with an accuracy of “as displayed”?
Options> Calculation>calculate is set the check-box “Precision as displayed”, but it’s not working!!
К примеру: In the cells are calculated values:
The format of each cell is specified the fractional part:2, - accuracy two digits after the decimal point.
If you add the digits of the number of turns = 47,6. Calc gives 47,62. Indeed, if you add up all the numbers with a given precision of 3 digits after the decimal point, we get approximately 47,615…
Thus, Сalc shows some values (with two digits after the decimal point) but calculation maintains maximum precision for him. It’s good, but in this case I kind of precision is not required.
I apologize for my bad English.

Please detail a bit or give a sample about what is not working.

Bug 98844 was created.
Bug 98844

As you mentioned Calc is always calculating in the background with maximum accuracy (about 15 digits).
To get only 2 digit you have to round each value before you add them up. The function is ROUND(value;2). Refer to you help file the correct name in russian and for the right delimiter.

Thank you for Your reply. Of course, you can use these “crutches”, but it’s easier to define precision “Precision as displayed” and previously it worked. Especially because I don’t need the rounding, the precision to two digits after the decimal point, else reject. This is not my wishlist, I adjust my calculations under the calculation made to another certified program.

I agree with @Grey_md 's statement.


I set Precision As Shown = True. No matter what # of decimals I show, the sum still = 47.6227. What should happen, is that as I decrease the # of decimals shown for the summed numbers, the sum should become 47.6240 then 47.6200 then 47.7000. But it does not change. I tried this on Win7 with the same incorrect result.

I went backwards through Portable Apps versions and it appears to last work at 4.1.6. When I re-open it in, it stops working and displays 47.6227

Win 10 / Win 7
5.0.4 Portable Apps -- no
4.4.7 Portable Apps -- no
4.3.7 Portable Apps -- no
4.2.8 Portable Apps -- no
4.1.6 Portable Apps -- it works
4.0.6 Portable Apps -- it works
3.6.5 Portable Apps -- it works