Calc v4.2.0 corrupts Excel XLS file

An Excel file updated using Calc and saved as an XLS for years with Open Office / Libre Office 4.1.2 is corrupted when saved by Libre Office 4.2. Formulas in ‘totals’ cells are lost and my copious comments point to the wrong cells and cells that never had Comments. The saved XLS file can not be opened by Excel 2000.

Restored XLS file from backup and tried saving without modifications as an ODS file. Virtually all Comments are missing from the resulting save and many formulas in total cells are missing.

Will revert to previous version (4.1.2) until 4.2 is actually ready for prime time.

Thanks for reporting the issue. For the sake of clarity, from the Release Notes page:

This is the first release from the 4.2 branch of LibreOffice which contains many exciting new features, and is targeted for early adopters and private power users — for conservative requirements, we refer you to LibreOffice 4.1.4 from the previous series.

If the data being worked on is important (i.e., the data of others or important personal data - not all personal data is important) then a conservative approach is always recommended. Calc in particular has undergone massive changes to the entire engine in v4.2.0. It will likely take a few point releases until all the bugs are worked out.

I downloaded and have the same problem, looking on the libre Office website v 4.2.2 is offered as stable, does that mean that the problems are solved?


A list of changes related to each point release can be found here. Unless there is a known bug (which can be followed) this is perhaps the next best list to determine what has been fixed.