Calc very slow to load .ods


I bought a new computer (i7 10th gen, 32GB RAM) and installed LO on a fresh Win10 copy. Everything works fine and snappy except Calc. Load times for .ods sheets are extremely slow (like 10-30 seconds). This affects both old documents created on my old computer with LO 6 and new ones. I just created an empty .ods sheet on desktop and even opening this takes the mentioned 10 to 30 seconds. I re-installed LibreOffice (stable 7.0.4), nothing changed. I disabled anti-aliasing and Skia, nothing changed. Interestingly, when another .ods sheet is already open, other .ods sheets open immediately as they should.
What can I do at this point?
Thank you!

Download the newer Version 7.1.0 and try again.

Download LibreOffice

Do you have Antivirus ON?

As it was said a year ago in TDF#139013 - “Please test with a clean profile”

Also, please check the method described in this bug - save in an alternative format and try to open

By the way, have you installed Java? What about the Use a Java runtime environment checkbox? Perhaps it should be turned off?

To test with a clean profile Menu/Help/Restart in Safe Mode

Tried both a clean profile (restart in safe mode) as well as 7.1.0, problem persists. It says “Loading document…” in bottom left corner for 10-30 seconds before the file opens. Problem is the same with JRE installed and with no JRE.

I saved one of my .ods sheets as .xlsx, and: it opens immediately. So it must be an issue with the format. What does this mean?

Did some further testing. New, empty .ods files seem to open immediately. Once I enter even just one letter in a random cell, they show the issue of slow loading time. When I enter data in a new sheet, save it, re-open and then delete all contents, the empty-again file has slow load times.

For comparison, a test:

A complete sentence written into the empty cell A1 and saved.

Calc - Test open File.ods

image description

Opens the file in 2 seconds.

Version: (x64) / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: default; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL

I read the question carefully again. It seems that we were looking for the cause of the problem in the wrong place. This is the clarification “when another .ods sheet is already open, other .ods sheets open immediately as they should”. It turns out that it takes a long time not to load the spreadsheet, but to open the office itself, launch Calc?

@JohnSUN that’s quite likely. The behavior is the same today, first .ods to load slowly, following ones open immediately if there is one other file open. Another issue is HighDPI, sometimes it works, sometimes it doesn’t, but that’s not the issue here and also less important.

Well, what about Tools - Options - LibreOffice - General.- Load LibreOffice during system start-up?

tdf#42673 may also be relevant.