calc's shift+space select current row line shortcut hotkey

Hello, When updating to Ubuntu 21.04 xfce, I believe LibreOffice was updated together. Now in Calc version, the shift+space hotkey stopped working at least for me. The behavior is inputing the space as cell content instead of selecting the current row. The other hotkeys ctrl+space and ctrl+shift+space remains ok. I checked in tools>customize>keyboard, and “shift+space” is still there and it is not possible to assign other key combination to it. Does the same happen to you? This impacts a my efficiency. I didn’t find complaints here and on mailing lists, maybe it happens just with me. Thanks for the attention and for helping mantaining the project.
EDIT: the problem was solved after a update made today 2021-06-20. closing.

Try restarting in Safe Mode: Help - Restart in Safe Mode….

Take a look at the guidelines at LibreOffice user profile - The Document Foundation Wiki to see if it can be caused by corruption in the user profile.

Add Answer is reserved for solutions. Please, click edit below your question if you want to add more information.

Reseting profile to factory and reinstalling the software didn’t work. Right now I am not able to compile, but I found that in some file the source, the select column (ctrl+space) and select all cells (ctrl+shift+space) have their treatment in docsh.cxx, but select row (shift+space) does not - core/docsh.cxx at 39c3574b799690d4405d9318a5ba221b5feaccbe · LibreOffice/core · GitHub or (which branch to choose from?); maybe i am looking at the wrong place, maybe it is treated somewhere else or maybe it was removed by accident. if someday I have access to a computer able to compile, I will test if adding awt in lines near 3050 and 3090 would solve the problem.

the problem was solved after a update made today 2021-06-20. closing.

If this needs to be a new thread, or a bug report, please let me know, but I think this is a broader issue.
I am having the same problem in LibreOffice, in Linux Mint 20.2.
Safe mode doesn’t help, it’s not the user profile, and all the other shortcuts that I tried which use the shift and space keys (including ctrl-space, shift-home, ctrl-shift-space etc.) work fine.
I bizarrely found that Shift-space does work when caps lock is on though.
Other shortcuts can be assigned to select the row without problem, but other actions assigned to shift space have the same issue–only working when caps lock is on.