Can I make base form fields follow locale settings?

If I change the locale settings in LO, decimal and thousand separators change accordingly. In Calc this happens even in cells with a custom format.

But in base form fields, as soon as I change anything in the format (like the number of decimal places) the locale settings selected in LO do not affect the decimal and thousand separators anymore.

I wonder if there is a way to make form fields work like calc cells so they use the LO locale separators even if custom format codes are used. Maybe I’ve just hit a bug?

I have a database document (.odb) connecting to an ODBC database. Copies of the .odb file are distributed to uses at several countries and they would like lo see numbers in form fieldas formatted according to their locale settings, as it happens with spreadsheets.

Please provide LO version, OS / version, and default locale.
Does anything change if you install the corresponding language pack for the intended locale and activate it before effecting your changes in the ODB file ?