Can I prevent Writer automatically deleting tabs?

I’ve noticed that when using Writer, all the tabs in front of a half-bracketed number or a number with full stop (e.g. 1) or 1.) will automatically be deleted when I press enter for a new paragraph. This does not seem to happen unless the line begins with a half-bracketed number or a number with full stop and only when there is text following the number with a space in between. Carriage returns (shift+enter) do not cause the tabs to be deleted.

When I’m typing up a permanent copy of notes I’ve taken during seminars I use the layout to help structure the flow, so these tabs are important to me. Although the problem can be fixed by pressing ctl+z immediately after the automatic deletion happens, it is slightly annoying. I was wondering whether this was meant to be a feature that could be turned off, although I couldn’t see anything relevant in the autocorrect options. There’s no change to the style either (i.e. it does not automatically change to ‘list content’ or the like).

I’m using Libreoffice on Linux Mint 20.1.

You will have problems if you insist on using Writer like a typewriter rather than a word processing application.

You could instead use list styles, or even the built-in direct numbering available in the context menu Bullets and numbering > Bullets and numbering > Numbering. More help in Writer Guide

If you insist on using tabs you can turn off the deletion in Tools > AutoCorrect > AutoCorrect Options > Options > Delete spaces and tabs at beginning and end of paragraphs also just below …end of line.

Thanks yes, I know this is not the ‘correct’ use of Writer but given that my colleagues frequently ask for copies I have to be able to send them out in a friendly file format i.e. docx, and styles don’t always translate properly across to the myriad versions of MS Word they use (much less of a problem now than it used to be, thank goodness). Ironically I’ve never used a typewriter :slight_smile:

Correct use of styles makes for a better translation into docx. Mish mash in; mish mash out


Tools -> AutoCorrect -> AutoCorrect Options...-> Tab: Options -> Option [ ] [ ] Delete spaces and tabs at beginning and end of paragraph

Hope that helps.

Thanks very much for the screenshot! I thought I had checked that list thoroughly but evidently not…