Can not install

During the install of it was looking for the old 5.2.2 msi file so it could uninstall the old version (Once an update is installed I never keep this file). As a result, the install rolled back. This never happened before, and as I said I never keep that file. I installed the Win 10 anniversary update just before this happened, so it is possibly related? I tried cleaning everything with CCleaner, so now I have no working version. So, really in a bind now as I need libreoffice to do some work. If reinstalling 5.2.2 works, where do I find that file; I can only find Can I manually clean everything out? I will get the exact error message when I get a chance, but the above is the gist of it. is the 5.2.2 release (RC2 became the release).

@erAck: that’s exactly what I hate about LO: confusion-inducing versioning.

You surely have a better approach to suggest then which would everyone confuse less. is the full version. Use that, not 5.2.2, which also saves using different code to make names.

RESOLVED. So after searching the Internet all afternoon I found the proper file “LibreOffice_5.2.2_Win_x86.msi” at some university somewhere. But as it turns out it looks as if it is just a installer (As noted on the header) that was renamed. So all I probably needed to do was to:

Download and rename this:


to this:


for it to work. Don’t ask me why; a Microsoft thing, a LibreOffice thing? I was then able to do a repair of the install, reinstall the old help file, and then install and the new help file without incident. What a two day nightmare.

Didn’t know Windows is that picky about the file name of the installer… thanks.

As you mentioned in question 82749 you used CCleaner that likely removed the msi file. Try to repair your installation using the 5.2.2 msi file (or x86_64 if you use the 64-bit version).

Thanks for the download. Will report back if it works.

No Go. Same exact problem. According to the pop-up message it specifically needs “LibreOffice_5.2.2_Win_x86.msi” NOT version (with the extra 2) in order to continue with the install. I searched for that version and could not find it anywhere. I suspect that would fix the problem.

Also, CCLeaner is completely unrelated to this specific problem; that was after… I always manually remove the msi before the next update to save space and that has always worked in the last couple of years

Going to try version next as soon as it downloads. Maybe it is the same as 5.2.2 since there is no 5.2.2.

Also, when I cancel out of the install (Because I have no choice) here is the error message:

“Error 1714: The older version of LiberOffice cannot be removed. Contact your technical support group.”

OK then, Is there at technical support group?

Man, I would really, really hate to roll back to my image backup and lose a brutal days time with the Win 10 Anniversary install on this slow machine, just to get to a working LibreOffice. That would suck big time!

Version also requires version 5.2.2 to continue. Out of ideas at this point, unless someone can find version 5.2.2 somewhere.

Well, just read what was written above in the other answer: get LibreOffice_5.2.2.2_Win_x86.msi and rename it to LibreOffice_5.2.2_Win_x86.msi