Can’t delete custom styles calc

Libre version calc

I cannot delete any of the custom styles. I did F 11 and right click delete. They are still there.

The style is not used anywhere in the sheet or other sheets.

I even created a different style to test delete and it won’t delete.

I have hundreds of styles built. I just want to clear them as they aren’t working right so I need to start over. Restarting the whole document would be awful and I don’t want to build this massive workbook all over again so I just want to try if I delete the styles and restart those

Suppose your OS is Windows. (What version?)
I cannot actually understand for what reason you thought to need hundreds of styles. I never do.
In what way did they “not work right” (miss to match your expectations)?
Did you have some experience with Calc before starting this “huge project”?

System is windows 2010
I just spent the last hour building three styles and reapplying them to 200 different dells. I saved the document and came back. Half of them stayed half didn’t
Experience with calc no. Experience excel tons. Not all or folks have excel but have Libre instead. We need a version of the workbook to accommodate them. So I spent the weekend rebuilding it in calc

There is no “Windows 2010”. Are you talking of Windows 10?
I’m working with LibreOffice and its predecessors, mainly in Calc, for about 20 years now, and never had problems of the kind you describe. I would really want to have at hand a file of yours showing the issue, to do some “research”. What is your smallest file of the kind? Best the XLS or XLSX, too, to redo the conversion.
Did you try with a reset user profile meanwhile?

If this is a document loaded from a file in the native .ods format, the document is not read-only, the style is a named cell style, no alert or dialogue was opened when you tried to delete it, then I can only suspect either the file is corrupted in a strange way or your user profile is. Try the steps described here to get a new user profile.

By the way: You should also be able to delete a named style by simply selecting it and then pressing ‘Del’ (no context menu needed).

Thank you. I’m going with something is wickedly corrupted. Since this didn’t solve it. I’m resigned that I’m starting again. At least the thousands of formulas I can copy over. I just won’t bring over any conditional formats. Thank goodness for paint once I get them built so I can transfer them to the other thousand cells!

Sorry. Simply don’t understand.
Can someone with a better English than mine help me?

I have been encountering the same problem today in Calc running on Debian. Following a suggestion from another forum I discovered that if any of the sheets are protected, the style editor does not work. Unprotecting all sheets fixed the problem. Would have been nice if there had been some appropriate error message though…

@frikdt Thanks for your suggestion. This solved my problem. I couldn’t understand why my [delete] or [modify] commands wouldn’t work and Styles were piling up on me. Two of the sheets in the workbook were still protected even though the one I was working on wasn’t. When I unprotected these, also, the problem vanished.

I am using LibreOffice under a customised Windows 8.1 OS. I abandoned MS Office just over five(5) years ago for my home system ( and I might be switching to an open-sourced OS in the future ). Right now I am creating a Task/Scheduling template in CALC that looks and functions more like OUTLOOK and can play nice with OUTLOOK and other programmes. This requires a lot of styles and conditional formatting for now before I can walk it into macros and programming. The list of defunct styles was just piling up maddeningly until I found your solution. Thanks a bunch !

Thanks a lot @frikdt, after much struggle with this exact same problem it was your solution that did it. And to think that I recreated a worksheet from scratch only to find out that the problem started happening again with the new one. This is a bug, since the current worksheet is unlocked and no toast is offered explaining why it won’t delete.

Wow… @frikdt, if I could upvote I would.

We faced the same challenge here. Using LibreOffice Calc version 7. In our case all sheets were not protected. The source of our challenge was that the spreadsheet contains multiple sheets & one of them use the old style. When a style is use by a cell(s) in any sheet(s), this style can not be deleted. To resolve this challenge we used Find and Replace style. For those not familiar with this, find the steps below.


  1. Using the LO Edit menu, click on Find and Replace
  2. Using Find and Replace window, under Find group, check both All sheets, then check Cell Styles option. Using the Find field select the appropriate old style. Click on Find Next button.
  3. The cell using this style will automatically be selected
  4. Using the Replace field, select the appropriate new style. Click on Replace button.
  5. Redo all steps above until all results are replaced with the new style
  6. You are now able to delete the old style