Can you get text prompt for icons in menu/toolbars

Libreoffice 6.1 running under Linux

edit as requested - Devuan Beowulf

About LibreOffice:-

  • Version:
  • Build ID: 1:6.1.5-3+deb10u6
  • CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3;
  • Locale: en-GB (C); Calc: group threaded

I’ve been using Libreoffice since it forked from openoffice and openoffice before that since it’s beginning. I’ve just upgraded to 6.1 from a few major releases prior, and am finding it almost impossible to find some of the tools I used to use. There is a lot more functionality and I don’t understand the ICONS.

I’ve managed to get some text prompts displayed but the tools → configure operation seems piecemeal and so far have only got icons and text for some elements - not all. For instance the toolbar elements “pushed” off the end of the toolbar don’t have text with them when you click on “>>”. Also things like the image filters have no text. It all seems so clunky that I MUST have missed something. I was hoping to get floating text on mouse over to help explain an icon - but that doesn’t seem possible.

Any advice - sorry if asking an obvious thing.

running under Linux

That’s pretty imprecise taking the huge variety of existing GNU/Linux distributions into account. Most of 'em make the packing of LibreOffice on their own, have different ideas of what to install by default and sometimes may have their own bugs. Please provide additional information, which distribuntion, which version of the distribution and which desktop manager (GNOME, KDE; LXDE, Xfce, Cinnamon …) you are using (Help -> About LibreOffice is a good resource for such info).

Please **[edit](** your original question. Don't post an answer, which is reserved for solutions on this site. Thanks in advance ...

I assume your “text prompt” is usually called tooltip.

I think they are always enabled. At least, I could not find a way to disable them.

Since I also get tooltips for the “toolbar elements pushed off the end”, it is likely that something went wrong during your update. I suugest you restart in safe mode.

LO 6.1 is becoming old by now (present stable release is and I don’t remember if Help>Restart in Safe Mode was already present.

Another possibility is a missing language pack (UI translation) but you didn’t mention your locale.

Also, the right UI handler must be installed (see Help>About LibreOffice and check VCL:). This handler depends on your desktop (GNOME and variants, KDE, basic X11). If a conflicting handler is installed, the UI may be completely broken. You didn’t tell your desktop.

You can edit (not an answer!) your question to add what is returned by Help>About LibreOffice. This would help a lot.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer) or comment the relevant answer.

In safemode the tooltips (thanks for the right terminology) appear.

I am investigating further. Thanks for the help.

Ok, moved ~/.config/libreoffice to ~/.config/ and restarted. Tooltips present. So now to setup stuff. I assume I’ve lost mostly cruft, as I’m really an emacs guy and only use office when I absolutely need to.

Thanks again