Cannot change font color in calc

I am unable to change the font color in CALC. I have used these products from Star Office 1 and only recently switched from OpenOffice. I try to change the font color in calc but the color displayed just goes back to black. When I look in print preview the color is there. Is there anyway to correct this. Currently I am working on an existing (openoffice) spreadsheet with numerous colors and the change would be very helpful.

I was having the same issue. As Lupp mentioned above, the issue is sometimes within the user profile.
Resetting my user profile solved it.

To reset your user profile:

  1. Close all instances of LibreOffice
  2. Navigate to your default user location
  3. Temporarily rename the user folder (I named it “bak”)
  4. Launch LibO Calc and test a font color.

If you have a lot of customization. I’m assuming you’ll lose it. FWIW, I narrowed down my error to the two files \user\registrymodifications.xcu and \user\pack\registrymodifications.pack– By deleting those two, I was able to retain the rest of my profile and those files are rebuilt when launching Calc.

Summa cum laude!
This is an extremely helpful answer. You obviously are starting a big carreer as a contributor to the help system of LibreOffice (° ͜^ °)

Thank you, Lupp, for the warm welcome and for pointing me in the direction of a solution. I owe you one, and I certainly owe this forum. Hopefully, this solves OP’s issue with minimal loss.

For linux users this is quite simple
Close all instances of libreoffice apps
Open your file manager of choice,
Navigate to /home/yourusername/.config/libreoffice/4/
(you likely will have to hit ctrl H to see hidden directories and files)
rename the user directory to something like user.old or user.bak
start libreoffice calc
add a comment to a cell
Your fonts during the edit and afterward when hovering over comment should be black on yellow as desired.

Are you probably talking only of cells with text content? If you switched on >View>Value Highlighting (Ctrl+F8) (inadvertently) this would result (for the screenview only) in black text constants, blue number constants, and green formulas or formula results.

(What’s your current OperatingSystem, what the exact LibO version?)

OS is Windows 10 Build 19041.685 with all current updates. LibreOffice Still (portableApps) is (X86) on a HP 64 bit system. Yes I am using CALC

Unfortunately you didn’t tell now if the attempted answer helped you.
Was the mentioned setting enabled? Did text colors come back after disabling it?
If so, the added information is dispensable in your case.
If not, someone else should step in with his (f/m) ideas.

I am also having this problem. I double checked-- and toggled-- the value highlighting. It is disabled. Still no luck. Windows 10 Pro v1909 Build 18363. LibO v7.0.4.2 (x64) - I recently updated but I’m not sure if it was an issue on the previous version.
Unlike the OP, my font color doesn’t show in print preview (I’m new here, should I open a different issue for this reason?). For me, the color is visible while editing the cell, but it returns to black once I’m done editing.

I checked for conditional formatting, even though it’s a new document-- nothing there.
This answer suggested disabling the change-tracking. It is.
I also tried “Clear Direct Formatting” and resetting the color. no luck.
Strange enough, the background color works fine.
It probably doesn’t matter, but I double checked the Options>Application Colors and Personalization. Those are all default

I’m afraid anybody trying to help further would need an example document showing the issue for the questioner.
(Very strange effects are sometimes caused by user profile corruption.)

Good call. I reset my user profile and got my colors back. After some trial and error I narrowed it down to the registrymodifications.xcu and \pack\registrymodifications.pack files. I will respond to the question with a formal answer.