Cannot copy formula

Recently I have a problem with copying formula’s. If I do a copy/paste or a Ctrl-c/Ctrl-v I end up with an absolute value in the cell not the formula.
I’m running rev under fedora 27.
Copy paste works fine from other accounts.
so I seem to have switched off copy formula some how.

In a bid to get back to default operation I deleted ~/config/libreoffice but the problem remains,

Any suggestions would be appreciated

This might not be the suggestion you want. I have learned through experience not to use simple Cntl-c/Cntl-v, except in strictly text-based documents. In LO Calc I use Edit->Copy and then Edit->Paste-special. The resulting dialog box gives you complete control over what is being pasted – numbers, formulas, text, formats, etc, It is powerful and few extra clicks, but worth it to avoid puzzling surprises that would slow me down.

Thanks for the suggestion, Apologies I was not clear when I wrote copy/paste I meant go via the menus Edit->Copy, Edit->Paste, as you suspected this is not the answer.

OK I’ve made some progress with this.
What I did not say in the original question is I am remotely accessing the server via VNC.

What I now believe to be the issue is something goes wrong with the permission on the clipboard when I execute the copy paste in calc.
I see an error message in /var/log/messages
plasmashell[643]: QXcbClipboard::setMimeData: Cannot set X11 selection owner

When you execute a “paste/special” it should come back with a dialogue asking you if you want to paste text, formulas formats etc. However what I see is a simple box which says:-
Source: Unknown source

 Selection - Unformatted Text

You said “Paste”. Did you mean “Paste-special”? There is a huge difference between the two separate choices.

Just simple Edit-> Paste or Ctrl-V. I’m only copying cells with simple formula e.g. =A2/2 and simple paste has always worked fine for these and continues to do so if I use another account.

If you get different results in different accounts, then it sounds like a problem with account preferences and default settings. You might spend a long time trying to find the source of the problem. I highly recommend using Edt → Paste-Special and checking or unchecking the relevant options. That way you are always sure of what will be pasted. It is worth the small extra effort.