Cannot edit any tables in base anymore

I made a new split HSQL database using the Split_HSQLDB_2.3.2_Wizard_v3d.odb I then made a few tables. I closed some, and then reopened them for editing (Fields…not data), all was fine. Then all of a sudden I could no longer edit any of them. Nothing I have tried makes any difference.

They all have primary keys. The database is registered. I followed directions to delete the .lck file but nothing. Quitting and restarting LO and even rebooting don’t help either.

Build ID: 1:5.3.2~rc2-0ubuntu1~yakkety0
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout Engine: new;
Locale: en-US (en_US.UTF-8); Calc: group

This is one of the drawbacks in the conversion to split DB. You can add or delete fields through the normal interface but updates must be done through other means. This can be SQL (from main screen menu Tools->SQL...) or an external program such as SQL Workbench/J.

I am just now reading up on a the subject (very old problem) which is still not fixed then. Whats the point of being able to use base to set up a split database, if you can’t do anything with it? I have not yet found a free external tool as good as base or better (GUI) for Linux, know of one?

I find this to be only a minor inconvenience. You can still do modifications but approached is different.There is another method to perform the “split” in the LO Base documentation (Chapter 11 Appendix) but I haven’t tried yet and it appears not quite complete. Have not seen any other DB front end programs on Linux for databases similar to Base.

Tried the mentioned method in the documentation. The change to be applied had /> at the end I had to omit but it worked. The DB was split and tables can be edited. The down side here is the you are still using HSQL v1.8 and not the new version.

“I find this to be only a minor inconvenience.” If you understand these things somewhat, then maybe, I am completely lost, every piece of info I find just opens a new can of worms. It’s like trying to flip on light switch that requires you to become an electrician first. I know because I am an electrician! I appreciate free and open source software, but will never understand the “everything but a GUI” mentality for Linux, where all of the freeware for Windows has one. Way to compete!