Cannot edit dialogs

Libre Office on Fedora 25 64 bit HP Pavilion Intel Core i7 and ample disk and memory.

I have just started looking at dialogs. Whenever I try to create or edit a dialog, Libre Office crashes.

I have tried rebooting and opening just one Libre Writer document, with no other applications started, but the result is the same.

If I do not accept the ‘Force quit’ option in the system dialog, I can run ‘top’ and see soffice.bin running at 100% CPU.

I have no problem editing and running macros.

Libre Office is very unstable on my system and crashes frequently when I am editing forms and macros.

Any ideas to solve these issues would be gratefully received.


I can’t say this is an answer, but it does appear you’re looking for possible alternatives. Here is what I would try next.

Based upon your post and that you are using openjdk, it’s a guess that LO is a distro install. On occasion (Fedora was one), the distro version had a problem while the same version from LibreOffice was fine. If so it may be worth a try. But before uninstalling/re-installing, you should reset the user profile (click here-look under “Resolving corruption in the user profile”).

The other item is Java. I know there are differences in openjdk and JDK from Oracle. Remove openjdk and install JRE from Oracle (JDK will work also but is larger download and only necessary for certain other development work).

Again, can’t definitely say this is the answer as this is the first time this seeing this particular problem. Using LO v5.2.3.3 (from LibreOffice) here on Mint18 and Xubuntu 16.04 without problem.

Try to run LO with a new UserConfiguration, for Example from Terminal with:

> soffice -env:UserInstallation=file:///home/owlbrudder/new/

Problem solved and it was entirely my fault!

I unwisely installed the access2base extension, not noticing the message which said a2b is a built-in part of L.O. 5+

I removed the extension and was immediately able to edit dialogs and the system seems more stable (touch wood)

Thanks for your suggestion karolus and I apologise for wasting your time. "8-(

— Later —

Last night everything was working, but this morning it is broken again and all I did was put the laptop to sleep over night.

I followed the advice from karolus to create a fresh environment with:soffice -env:UserInstallation=file:///home/owlbrudder/new/, but this has made no difference.

I am at my wit’s end. Clearly there is something unique to my system which is causing this because a general failure to edit dialogs would be a show-stopper for LO Basic/a2b programmers.

Any further ideas would be gratefully received.

— Later still —

I ran soffice with the --backtrace option:

It does not mean anything to me, other than the obvious observation that ‘selection changed’ seems to be a problem, but this appears before the LibreOffice Document Recovery dialog appears.

LO is using Java runtime /usr/lib/jvm/java-1.8.0-openjdk-

I have removed all extensions other than those built in to LO5.

I am seriously running out of ideas.

Is there any other debugging I can undertake?

The problem was indeed the specific version supplied by Fedora for F25. I installed the LO Fresh version of 2.3.3 and the problem went away permanently.Thanks for the tip, Ratslinger