Cannot keep Lead "0" in numbers

I like to use military time and when I enter the times with a lead zero, the table deletes the lead zero. Example: I enter 0135 as the time and the program deletes the “0” and leaves just 135. I think if I could format the column as characters rather than numbers it would keep the “0” but I can’t find the information that tells me how to make the column “characters” instead of numbers. Can you help?

I think you want to format the time as “text” which should actually be the default in Writer (word processor) and there should be no problem writing 0123. Your tag says Writer. If, however, you are using Calc (spreadsheet) you just need to click on the cell to select it, then use menu Format → Cells, then choose Text from the list.

I kept looking and finally found the answer! In Writer, I went to “Tools”, “Options”, “Open Office Writer”, “Table”, “Input in Table”, “Number Recognition” and unchecked the box! This allowed the lead zero to remain in the table!

Thanks for the assistance!

Interesting. In my (limited) experience, LibreOffice Writer, even in tables, treats all “numbers” as text, except of course the page numbers which are defined as numbers.