Cannot load network spreadsheet

When I try to open any *.ods file that’s located on a network (Linux Samba) drive from a Windows 10 (v1511) client, a window opens, a LOADING green bar zips across the bottom of the screen, and the window is left completely blank. At this point Calc is Not Responding. A lock file has been created on the network server and it remains after I forcibly close Calc. Opening network *.odt is not a problem, just *.ods files. Furthermore, I can open the *.ods file without any problem from an Ubuntu 16.04 client. All the clients are running LibreOffice I have tried uninstalling and reinstalling LibreOffice on the Windows client and I have tried deleting the LibreOffice user file. Nothing changes the behavior. Do you have any suggestions?

Can you copy it to the local Win 10 machine and open it from there?

Yes, I can copy it to the local machine, but no, I can’t open it from there. I can create *.ods files on the Win10 machine and then subsequently open them there. I have not yet experimented to see if I can create an *.ods file locally, save it to the server, and then subsequently open it from there.

I solved the problem by uninstalling 64-bit LibreOffice from the Windows 10 machine and installing in its place 32-bit LibreOffice Having done that, all the above issues have gone away.