Cannot Open Stored .odt Documents

Windows 10 recently did an automatic upgrade to ver. 1903. At the time I was running LibreOffice 6.0. When I tried to open any of my stored .odt documents, access was denied. I tried upgrading to 6.1, but the problem persists. However, if I type a new .odt document, it opens without a problem, even though the root-address is identical in every detail, except the name, to the old files to which I am being denied access. Even if I go to the root folder and double click on the files, the new one opens and the old ones are denied. Any help would be appreciated. Dennis

When I tried to open any of my stored .odt documents, access was denied.

What is the error message exactly? How do you try to open a file (LibreOffice open, then open file or double-click in File Manager)?

Does this problem exist with other “pre-upgrade” files from other application?. If yes - then the update might have changed permission and you need to take ownership and/or reestablish permissions on your old files.

ebot - When LibreOffice opens and displays “Recent Files”, I double click on a file and get “Error - Access to C:/ -file root- .odt was denied”. When I use “Open File”, I get “The file cannot be accessed by the system”.

Opaque - I have not noticed any problem with other “pre-upgrade” files. Besides totally knocking my printer out, which I still haven’t solved, this is the only problem I’ve found. How would I check “permission”, I don’t use a password as this is a home computer for strictly personal use. Thanks for your help.

C:/ -file root- .odt doesn’t look like a valid filename and this points to some corruption of your user profile - Try to start LibreOffice in Safe Mode and check whether the problem is gone. Since you obviously are still able to start LibreOffice you may use Help -> Restart in Safe Mode to start in Safe Mode (This use a fresh user profile, so don’t worry about missing thumbnails of recent used documents).

Sorry Opaque - file root - is an abbreviation for "C:\Users\Dennis Neff\SkyDrive\Documents\TERI’S ADDRESS.odt , for example. This is identical, except for the “TERI’S ADDRESS” file name, to the new file that opens. New meaning a file made since I upgraded to 6.1.

No problem - anyway try the Safe Mode approach. It does not harm but may help to exclude a profile corruption as a reason for your problem.

SkyDrive ist OneDirve, isn’t it? Old name <> new name. Your system performed the Windows Feature Update 1903 and now you experience missing permissons on some files on the Microsoft SkyDrive. Hm - what could be wrong here? Did Microsoft mess up it’s own technology once again?

From the path in your comment is clear that SkyDrive is part of your Windows User Profile. And guess what, this has been created completely new. MS transfers Data from the old profile to the new one each time they force such Feature Updates. This works more or less well. So I can imagine a correlation.

Try to take your files out of the SkyDrive onto a local drive. Hopefully it let’s you access the files at least on file level. Test if permissions are still lost. Chance to reset permissions are much better on the local side. If this works, clean up your (two) SkyDrive(s) or even delete it (them) and set it up again. Bring your files back on it.

Remeber to keep Backups independed from things like Cloud Storage.

Cookievore - You’re absolutely right. When I went looking for “SkyDrive” I found “OneDrive” instead. However, the new documents I make in 6.1 still use the “SkyDrive” terminology and it opens them fine though they are actually in the “OneDrive” root. I don’t know how that can be, but it is working that way. Go figure. At the same time, I can copy the “Documents” file on that root and will try to place it on a local drive as you suggest. The only problem is that I will have to change the “root address” of each file individually, but it might be the only way I get access to them again.

By the way, I tried to delete the old “SkyDrive” file, but it wasn’t an option.

Cookievore - Just figured out “SkyDrive/OneDrive”. They are both in the Cloud and they are sync’d so you can use either name in the root address. At the same time, you apparently can’t copy or move a file from the Cloud to the harddisk, that is why I can’t copy the file and move it to a local drive. All of this still doesn’t answer why the old files won’t open, however but new ones will.

Why don’t you tell the full story from the very beginning.A bunch of comments were needed until it gets clear, that you are using a cloud service.

Opaque - I had no idea I had a cloud service. I’ve never used it for anything else and I just assumed that it was where LibreOffice stored all its .odt documents. I certainly didn’t ask for it or request it. Is there some way I can get the files back down onto the harddisk? I had no idea there was a choice.

@anon73440385 , be forbearing, a little, since this crap is hooked so much seamless into the system that less IT oriented users don’t recognize this at once and overall.

P.S.: Ah, was right with my presumption as I read in the previous comment.

@Dionysus, this is unfortunately not LO related and we can’t help to much on how to recover files from SkyDrive on this askbot. It’s scope is LO or it would flood the banks. But one more hint: At least OneDrive shoud have a Web Access / Web GUI. So you could access the files with a browser and you could be able to download them somehow bypassing the Windows OS. Godspeed!

@Cookievore - not at all. I got no understanding, if people don’t even know, where their files are stored. If you use a knife you should learn which edge is the sharp one.

The ability to call Recent Files works only if the files are still in the same location.
If you use the file manager to move files, they can not be accessed by LibreOffice via “Recent Files” because the link has been lost.

ebot - I haven’t moved them, however I notice that if I follow the root address there are two SkyDrive files. The original one I established when installing 6.0 in 2016 and a new one established when I upgraded to 6.1 two days ago. Unfortunately, it won’t let me copy all the documents back to the old file which is now empty. However, this problem existed before I did the upgrade, so I don’t think that is the problem.

For anyone whose LibreOffice “Documents” are stored on “OneDrive” or “SkyDrive” and the old files will not open, you can go to “Word Online” at When it opens go to Documents and you will find all of your LibreOffice documents there. They will open and you can edit them, download them onto your computer or print them out. I bookmarked the Documents page in my browser and will go there for old files. New files open OK. For me, this problem applied to Ver. 6.0 and 6.1.