Cannot past an image from the web into a LO document

Hi all,

I’m wondering if the following might be a bug or not. I’d like to copy an image from the web into a LibreOffice document, a calc sheet for example.
Normally I would right click the image in my browser (FF), select ‘copy image’ and start a new calc file. There I do a crtl+v and nothing happends. No image appears which i find odd. I’m sure it worked before.

When I right click the sheet and select past, nothing will happen eather. Only when I do a ‘past special’ and select a bitmap, the image will appear.

Some extra information, I enabled the Graphics and objects option [the Menu Tools → Options → LibreOffice Calc → View → Display → :ballot_box_with_check: Graphics and objects [enabled]

I tried this on Windows 7 LibreOffice and Ubuntu 10.01 with LibreOffice

Could this be a bug?

Thanks for your responces.

Don’t think this is a bug. Confirmed the same behaviour on Windows XP SP3 in LibO and AOO 3.4.1 in Calc ONLY. In Writer image could be simply pasted. In Calc works only with “paste as…” and selecting “bitmap”.

I found out about that too but i guess it should, as in any other editting program, work with crtl+v aswell?

@rost52, can you give me the link or bugnr of the post you made in the bugtracker?

I also experienced a lack of pasting functionalities in LO Impress. A lack refers to functionalities compared to MS PowerPoint. To me this appears as questions of image formats which can be handled by LO. As I am not an expert on image formats, I do hope that an expert on image formats would give explanation on which formats can / cannot be handled by LO.

As I also reported my earlier observation as a bug a few month ago and learned that it should have been a enhancement request, it would be great if the aforementioned expert (or a developer) could also comment on the status of development.

I can confirm the copy & paste situation as mentioned in the firs post. I am using LO on XP SP3)


@ROSt53, Could you please update your answer w/the bug # per request by @EzMe? thanks

@ROSt53 – Bug #, please?

Hi @ROSt53, @EzMe,

If you still can’t use CTRL-V to paste images into Calc (or Impress) and would like to see this feature added, please file an enhancement bug and provide as much information about this new feature as possible. Don’t forget to mark your bug as an ‘enhancement’. The QA team will be happy to help you triage your feature request in the bugtracker.

Please post a link to any bugs you file in a comment below using the format “fdo#123456”.


@qubit1 and @EzMe

Sorry for not seeing your request for the bug information earlier.

I checked MyBugs but could not find the bug report. I only found an Impress file I still have, Therefore the bug report should have the title “Lost Character Paste GDI Metafile” or similar. Reporting date should be 26-May-2012 or a bit later.

Maybe someone else can identify this bug report again.

@ROSt53: You filed 7 bugs during May - Sept 2012

If none of those matches your bug, please refile!