Cannot save doc in LO

Hi, everyone!

I’m running into a problem that I need to ask about.

I was using LO 6.0.6 (64-bit), started running into a save error, preventing any type of save. Did a save-as, which worked. Immediately exported my doc as a pdf to back it up, then closed my original LO-format doc without saving.

Couldn’t figure out the error, so I uninstalled 6.0.6 and installed LO Tried it all again. Same result. The LO file is now in a “save loop”, where the green process indicator will complete to about 30-40%, the disappear, pause, then repeat. I was finally able to close LO by using the Task Manager.

The document that I’m working on consists of 1 long table and nothing else. I reopened the file (forced to go through recovery process) and sorted the table. When I try to save the file, I get this message in LO

Error saving the document p***********:
Write Error.
Error in writing sub-document content.xml.

Does anybody know what is happening?
Does anybody know how to fix this?
If this problem can’t be fixed, is there a workaround?

What OS and version are you using?

Though it seems unlikely, maybe the file somehow got flagged as read-only by your OS? In windows, you can right-click on a file, go to Properties and see if the Read Only attribute is checked. If so, uncheck it. It’s also possible that a LCK file remains in the folder with the file. A .LCK file prevents multiple people from opening the same file at the same time. It’s temporarily created and deleted again when the file is closed. If LO crashes, the file can possibly remain and cause problems.

It’s also possible you have a corrupt LO process hanging in memory. If you open Task Manager and see several Libre Office instances, you might want to end all of the Libre Office tasks (after saving your work). One of the hanging processes might be locking the file so it can’t be written to. To view LCK files, you might have to enable seeing system files, as some systems hide them. Since I’m a semi “power user” I like to see all hidden files always. You can delete the .lck file.