Cannot set language for spell check

Running Version: in Mint 18.
In Options > Language Settings > Languages
I have
User Interface = Default - English (USA)
Locale setting = Default - English (UK)
Default languages for Documents
Western: Default - English (UK)

If I run spellcheck in any document it doesn’t find any errors, but the Text Language is set to [None]. If I click hte drop down the only other option is English (USA), but I cannot select it, just goes back to [None]

This seems to be a problem in all modules.

How do I get spell checking to work?

Just had the problem again with a new install and found this while searching - worth adding to this that it is necessary to install hunspell-en-gb as well.

Thanks @micksulley - that fixed it for me: sudo apt-get install hunspell-en-gb. Only then could I set the test language to ‘English (UK)’ under Tools > Spelling and Grammar. Then at last all the the squiggly red lines appeared in my document:).

Same here, @micksulley’s answer was the solution. Thanks.

Thanks @micksulley - this ( running the hunspell-en-gb installer from command line terminal: sudo apt-get install hunspell-en-gb ) worked for me too running Libre Office Writer on Trisquel 8.0 LTS Flidas GNU/Linux and wishing for English(UK) spell check. When I exited and restarted Libre Office spell check was working correctly with propah UK English.

Thank you @TrisquelUser you have saved me a huge amount of pain by commenting for Trisquel and putting in the command line text. :slight_smile:

When you don’t have a language assigned to the text of your document, assigning a language in the spell check dialog box isn’t going to help you - the language listed there is the language assigned to the text being checked, and if no language was assigned, then the spelling won’t be checked. Period.

Check out Tools - language settings - Languages and check that a language has been selected as default language for your documents, and make sure that the language listed there is actually installed. Also check that a language has been set in the Default paragraph style (and that language has to be installed of course). Note, thanks to Radish: you can select the language for text on the Font tab of the paragraph style dialog box.

A quick fix for most spell check problems is to reset your user profile. See Frequently asked questions - General - The Document Foundation Wiki - important: rename the folder, don’t delete it.

If this answer helped you, please vote it with :heavy_check_mark: (here on the left). That will help other people with the same question.

“Also check that a language has been set in the Default paragraph style . . .”

Okay, Floris. But how do we do that? I’ve looked at my Default paragraph style settings and nowhere can I see any setting that allows assigning a language to the Default style. Where is the setting?

I found a setting in Paragraph Style: Default Style > Font (tab).

Do the following:

  1. Open your document.

  2. Keyboard CTRL+A. This should select all the text in the document.

  3. Look at the very bottom of the LibreOffice Writer window - the grey bar at the bottom of the window. If you see an item there that reads “[None]” right-click on that item and select “English UK” - that will setup all the text in the document to be checked as English UK/English GB. If that is what you want, then save the document and you shouldn’t have the same problem with it in the future.

Incidently if you downloaded the LibreOffice HelpPack English-GB and installed it to the system then to get it to work with LibreOffice you need, in Language Settings, to set the User Interface to English (UK). If you don’t do this then when you click for help in LibreOffice then the help page will be opened in your browser i.e. you will be using online help (not offline).

1 Like

That’s direct formatting, and that’s bad style, pun intended.

Option 3 worked for me. Thanks Radish

:+1: thanks

I had this problem too.

My problem was complicated by my system is NZ language and that’s not really a language. I am on Kubuntu 18.0.4 and LibreOffice Anyway what I did was…

Initially I installed some dictionaries using tools → spelling → options → get more dictionaries online.
I still couldn’t select anything but “none” from the languages in tools → spelling.

I installed things from the os repository that talked about spelling. I can’t remember what they all were. Nothing much changed. I do remember installing the hunspell-dictionaries from the Discover app.

Then I noticed that “English (New Zealand)” was written at the bottom of the LibreOffice program. clicking on this I could change to USA English. I then changed the default language to USA from tools → options → language settings → languages → default languages for documents. When I selected “English (USA)” here I see “ABC” with a tick.

I know this is an old thread, but I’m having this same problem on a newly installed LibreOffice When I go to spell check in Write it always comes back as The spellcheck is complete. Even highlighting a known misspelled word and spell-checking gives no error. Tools > Options > Language Settings > Lanugages, shows Default Lanuages for Documents, Western: English (USA). The info-bar at the bottom of the composition window shows “English (USA)”. I have installed hunspell-en. I’ve logged off and rebooted. Nothing seems to work.

When I open the spell-check function, the “Text language:” setting at the top has nothing and the Drop-Down has no entries.

What is the solution?

  1. Read this tutorial.
  2. If you can’t find an answer, read these guidelines and ask a good question, don’t hijack an existing one.

gabix: that tutorial link is really old, 2007, and several of the things it asks to check for aren’t on my Writer. As to “hijacking”, each forum seems to be different on this policy. Some don’t like a dozen of the same exact problem being posted in separate threads. Nevertheless, per your request, I’ve created a new question: No spell check on LibreOffice Write