Cannot solve latest upgrade issue or access program folders

I tried an update link to, all went normally for a bit then an error dialogue box appeared
It eventually told me I had not permission to access /program folder, despite it being my sole owner machine logged in as administrator. It also threw away my previous version so no files would open. Same effect on help file update.

I created/LibreOffice2/program folder etc and reloaded as a custom install which worked ok so I can access my work, BUT
I cannot access or delete unwanted LibreOffice folder or daughters. It says I need permission from SYSTEM but I cannot change permissions to access, so cannot do anything. There are also several different owner permission sets and I don’t know what they are but cannot delete them either.
PC is an i9 based latest build Windows 10 home using RAID SSD to load software. Has all worked perfectly up to now, don’t understand why I can’t access and change permission or delete?
My duplicate LO seems fine.

Maybe it can help you?

In your description of your issue it looks like you are running LO from a 2nd storage device, an SSD. That you are manually creating a program folder or moving LO from it’s normal location over to the SSD. I suggest you try to reinstall LO, accept the default location and see if it then runs as expected. If it does then you might have done something wrong with your access rights on the SSD device. Also if you move LO from one location to another, it is quite possible that this will disrupt registry settings, related to LO.

If you want to better understand what you are dealing with then read up on file access rights for the NTFS filesystem used on Windows10. You might also want to look into what registry keys LO requires modified if you move it from one program folder to another.

Thank you for your reply

No the C Drive is an SSD RAID, D is a conventional RAID on my new machine as Aorus Master M/Bd permits this. I didn’t move the previously functioning LO at all, the updater threw it away leaving an apparently empty folder and no shortcuts etc, then refused to upload the new version into the previous folder as it said I didn’t have permission despite being logged on as administrator, and it having already operated in the folder! All drives have previously worked OK and loaded S/W OK

The use of a new folder was simply an afterthought as a way of getting LO to load at all, and worked fine
I now still have Programs/LibreOffice/program which I can’t open or delete

File access rights advice is typically re Security tab of properties etc, and this is what I tried but I don’t have encyclopaedic knowledge of it so I will have another look How to take ownership of files and folders on Windows 10 | Windows Central looks like a good start

Any more ideas welcome