Cannot start any LibreOffice application on my PC

I’ve been unable to run any LibreOffice (LO) component (mostly calc and writer) on my primary Windows 10 PC for the last 6 months. (It used to work just fine.) Attempts to start any LO app results in an Application Failure;

Faulting application name: soffice.bin, version: 7.3.1.3, time stamp: 0x621d53ef
Faulting module name: cppu3.dll, version: 7.3.1.3, time stamp: 0x621d22b4
Exception code: 0xc0000005
Fault offset: 0x0000000000020e3e

I’ve been working on this problem off and on now for 6 months. Here is a summary of the fixes I’ve tried;

  1. Downgrading to previous versions of LibreOffice (LO) that once did work on this PC.
    
  2. Upgraded to newer versions of LO released since the problem appeared.
    
  3. Ran the install/repair option on each LO version tested.
    
  4. Upgraded LO from 32-bit to 64-bit.
    
  5. Copied soffice.exe, soffice.bin and cppu3.dll files from another PC where LO does work. (Matched LO versions)
    
  6. Attempted to start application in safe mode.
    
  7. Ran Windows repair utilities. Rebooted more times than I can count.
    
  8. Deleted the personal LO profiles in %APPDATA%\libreoffice\4\user and rebuilt.
    

I’ve probably tried a few other things but, in the end, nothing works. Every fix attempt results in the same error in module cppu3.dll. LibreOffice is running fine on my other PCs, but not on the one where I do most of my work.

Any idea what is wrong? Any ideas on how to resolve this issue??

General Installation Issues (Windows)

Thanks for the info.

To clarify, I had an installation of LO that was working fine until some time in early December 2021. I cannot identify the exact date and I’m unaware of any connection to updates to my Windows OS or other software installed.

For the record, I’ve never encountered and error when installing LO. My problem is that the program(s) fail to launch.

Just to be sure, I just downloaded version 7.3.3 and performed an install using the guidance provided in the “General Installation Issues (Windows)” link referenced above. The download was verified using the sha256sum function. For the installation, I temporarily suspended my anti-virus (Norton) and my Brother Control Center (BCC3) software. The installation completed without error or any problem notification. I tried opening calc, writer and the LibreOffice general app. None of them would run. All threw the same error referencing soffice.bin and cppu3.dll.

Not sure if a slightly different user profile reset would work for you…
According to this https://ask.libreoffice.org/t/libre-office-doesnt-start/61696/4

First make sure there are no instance of LibreOffice running.
Then you would want to remove starting from the “4” under the “%appdata%\Libreoffice” directory (not just the 4\user directory).

My cppu3.dll file is not missing. The error message in the windows log indicates the crash occurs inside cppu3.dll after it is called from soffice.bin.
I’m certain that my version of cppu3.dll is OK since it has been installed, removed and reinstalled over a dozen times from at least 7 different release versions of LibreOffice. I’ve also copied cppu3.dll to the affected machine from another PC where LO runs fine. The programs still fail to run.
As an aside, I would advise to never install a program component from a source other than the official LibreOffice project. Components from third party suppliers could easily harbor viruses, keyloggers, spyware/ransomware and all manner of malicious code.

A quick warning there…if this is the same for Windows as .config/libreoffice in Linux, then that will delete any My Macros macro libraries. I suspect, though, that the OP has already taken actions that would do that.

For the record, removing the “4” directory did NOT work.

There are 5 repair options in the link by @Hrbrgr . I would say that Steps 4 and 5 are sensible common fixes.

Step 4: I know you have Norton so presumably it did not find malware. You could do a scan with a different AV such as Defender (built-in but not running) or an online one with McAfee or other known AV

Step 5: Using System File Checker (SFC) to scan the system is a pain but commonly prescribed.

Are your printer and video drivers up-to-date? The printer driver might be culprit, maybe change the default and reboot before starting LO?

You could post a bug report and attach your crash report, see First steps to take before submitting a bug - The Document Foundation Wiki

As an interim measure, you could try running a portable version of LO. It is self-contained so will probably run fine.

1 Like
  • Over the last several months, I’ve scanned the LO files multiple times with Norton, Defender, Malwarebytes and Spybot. Never found any problems. I’ve also copied known good files from one of my other PCs where LO does work. As far as I can tell, there is no file integrity issue.
  • In the past, I’ve also run the Microsoft Deployment Image Servicing and Management (DISM) tool followed by the System File Checker (SFC) tool. I just ran them both again and the problem is still there.
  • I’m using a network printer, so the affected PC is using the same driver package as other PCs that do not have this problem. BTW, the printer driver hasn’t changed since 6/21/06.
  • I’ve been using a video driver from 11/9/2021. I just updated that to the latest driver dated 5/4/2022. I’m still getting the same LO error after updating.
  • I’ve just installed an instance of the portable version of LO. That seems to be working OK. It’s not that different than my current work-around of using LO installed on a VirtualBox linux machine that runs on my primary PC’s Windows 10 platform.

I’m not being anti-LO here. But I think that may be the main library for the UNO runtime. So, I wonder if you have tried installing OpenOffice. It seems like OO working or not might tell us something.

Even if that was running it wouldn’t tell anything about the UNO runtime, which comes in completely different versions built by different compilers and tool chains.

:frowning_face: Guess I’m just too used to more proprietary frameworks.